5.0.R1-GTK3 link → GIMP not OK ?!


(lux) #1

Hello… (Am I in the good tread ?)

The link to GIMP don’t work with my RT 5-0-r1-gtk3
Is the problem know ?


(Morgan Hardwood) #2

http://rawpedia.rawtherapee.com/How_to_write_useful_bug_reports


(lux) #3

Oh, I am tired by all the meanders that we impose more and more sites to communicate.
Moreover, the problem of language, if it does not pose a problem for simple things quickly becomes painful for more complex things.
I’ll just drop and just use
Yes too tired !


(Mica) #4

Opening with gimp is working just fine for me on Debian 8. It is difficult to help you when you’ve provided so little detail.

Is there an error message? What version of the programs do you have? What OS are you running? Can you open gimp from the command line?


(lux) #5

I would like to start GIMP from RT, as usualy, but with this version, I’m not able to install the parameters neither
the first line, nor the last, when I write the full address of the .exe of GIMP.


(David Wilson) #6

Are sure you are selecting the same directory ?

\Program Files\GIMP 2\gimp-2.8.exe

is not the same as

c:\programmes\gimp 2\bin\gimp-2.8.exe

Does the above line start gimp if issued from the command line.


#7

Perhaps selecting “autre ligne de commande” could help?
And you should be able to launch gimp by double clicking on gimp-2.8.exe


(lux) #8

Thanks a lot for your answers.
@David : Yes this directory is good
I have two prog directory ; Programmes for 64 bits (?!) and Program files (x86) for others.

Both, GIMP and Rawtherapee are running in “Programmes” directory.

here is the directory :


(Mica) #9

If you’re running anti virus, please disable it and try.


(lux) #10

Thanks for your help paperdigits,

I have a part of the the solution and I am very surprised.
The directory noted “programmes” works as "program files"
And shall be used with this latter name.
I have not yet found the reason of this problem ( It is a new official installation on a new, blank disk of a Win 7-PRO).
All my other software works except this part of RT.
I can’t rename that directory.


(lux) #11

I will compare with my old PC (running with Win7 premium).


(lux) #12

The answer…

http://www.forum-seven.com/forum/topic2296.html


(Mica) #13

Can you put the actual solution here instead of the link please? I don’t speak French or else I’d do it.


#14

To synthetize this lengthy post
In Windows7 (and also on my recent windows 10 installation), when you are localized (in french here), there is a microsoft hack to show in the windows explorer the translated name (for instance “programmes” in french).
As it is not a symbolic link (NTFS junction specifically), you cannot use this name elsewhere.

For instance in DOS command or in bash script, I use “program files” to access 64bits applications. If I use “programmes” there is an error.
In W10, when you copypaste the path in the explorer, you get the real “program files” name.
It is to be confirmed by other Windows 7,8 10 users.

1- If not present, a precision in rawpedia will be welcome.
2- in rawtherapee, if the exe doesn’t exists, there is no warning even in verbose mode.
Is it possible to verify the existence of the exe in the preference window?


(lux) #15

Thank you, gaaned92 ; nice explanation …
But, a question: why “program Files (x86)” and ProgramData "are not translated?
Bug?


#16

Nobody can answer. These are the idiosyncrisies of Microsoft :open_mouth:
To provide in windows explorer a name that you cannot use in other SW is rather stupid. Windows users learn to get used to that :astonished:


(lux) #17

Thanks a lot for your answers