A bug in noise processing.

A bug in noise processing. Maybe it was reported?
I made a piece of video (299mb) to show the problem.

Hi, can you share the raw file as well? Thanks!

And maybe the .arp file until the point of activating NR? I tried to reproduce by copying every value starting from “neutral” profile, there was no problem for me.

I attach the raw and the xmp of the photo seen on the video.
my computer is running linux debian stable.

raw : https://www.philippedeletree.eu/uploaded/divers/20201022_0010.NEF
xmp : https://www.philippedeletree.eu/uploaded/divers/20201022_0010.xmp

Maybe this bug comes from my computer?
To test at home…

This XMP does not belong to ART. ART saves edits in its own .arp files.

Seems to work fine for me.

What build do you use, where did you get your ART from?

If not already in use, does the official 1.13 build work for you?

I update ART as soon as A.G. updates its development version.

  • I watch the news: Bitbucket
  • I update immediately.

I don’t have an .arp file with this image. When the error occurs on the development version ART stops and the .arp file is missing.

Can you try saving explicitly the arp before enabling noise reduction and attach that? I also tried to reproduce and failed… Also, can you post the AboutThisBuild.txt file that is generated in the build directory? Thanks!

I will do it tomorrow. The family arrives…

Noise reduction is not active in this raw development.


For the records: No problem on my side with 1.13 stable and ART_master_1.13-28-g3ddac71a8_W64_generic_220511 from gaaned.

thanks for the additional data. I’ll take a look asap