AffinityPhoto as external editor in Windows


(Jan Erik Taylor) #1

Hello,

I’m a new user to Raw Therapee and I’m liking it very much. Does a good job on my Fuji RAF files. I have also bought Affinity Photo for some extra editing, and was wondering how one sets up Affinity as an external editor in Raw Therapee on Windows. I searched this forum and I tried googling, but I only found how to set it up on a mac. Does this mean that it can’t be done on windows or are there very few Raw Therapee windows user out there?


#2

@jetstacker
RawPedia http://rawpedia.rawtherapee.com is the reference documentation of RawTherapee.
For your question, have a look here http://rawpedia.rawtherapee.com/Preferences#External_Editor


#3

I’m not as pc savy as most of the people here, so it took me a while to figure this out. Here’s what happened. A few years ago, I had a problem with getting an external editor to come up in Windows. Apparently I was not putting in the full path. Putting in less than the full path of the file, it just led me to where the file was on my pc. Then I tried what I thought was the full path, that didn’t work at all. Then, I put " " around the full file path and it worked just fine.


(Jan Erik Taylor) #4

Thanks for the replies. Seems I had a bit of a laps in my cognability and wrote the path but ended it with .app, since I had been reading the MacOS directions instead of .exe. It works fine now.


(John) #5

Waking up this oldish thread because I can’t get it to work either. I used the reference that gaaned92 pointed out, and it seems really simple, but it doesn’t work. I also tried the double quotes that DenB recommended and still no luck. Is anyone else using Affinity Photo as their external editor? I’m using version 5.4 of RT on Windows 8.1. (I have Affinity set up as “external editor” in Faststone Image Viewer and it works fine.)

Edit: Figured it out so I’ll post it here for others. When you’re in Preferences, the External Editor section, there is a little “button” on the left by each line (GIMP, PS, or custom). You have to click the button in order to set that editor, but you DON’T have to click the button in order to TYPE in the file path for the program! In my case, the button for GIMP was selected, meanwhile I typed in the pathname for Affinity and hit OK and it did nothing. Once I clicked the button next to “custom” and hit OK, it worked.