ART another crash with Manjaro Linux (fixed)

I’m opening another thread about this one because it’s not necessarily the same issue.

I have the impression of not having succeeded in a debug compilation, nevertheless gdb is verbose.

Some information about my hardware:
Lenovo ThinkStation P330 Tiny
Intel(R) Core™ i7-8700T CPU @ 2.40GHz with UHD Graphics 630
nvidia Quadro P620 GPU 2048 MB
Onboard memory 16213 MB
System 5.15.74-3-MANJARO

The system crashes when using heavy modules like “Noise Reduction” if very solicited. (3,0 Ko)

Thanks but the gdb log contains no backtrace unfortunately…

I’ve tried everything to get a debug, either the build goes through and I get a standard version, or the build crashes.
It’s not enough to change “release” by “degub” in the PKGBUILD for it to work

Can you be more specific about this crash - whats the actual error you are encounting?

You can use this PKGBUILD to create a debug package of the latest release version (1.16.3).

Crash of my own making. :confused:
Thanks for the PKGBUILD, I will try it.

Thanks, it looks like it’s good

Reading symbols from /bin/ART...
(gdb) r
Starting program: /usr/bin/ART 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/".

It remains to reproduce a crash, it is not systematic

No better, ART died before gdb could log.
log.txt is empty
I don’t know gdb well, maybe other commands are needed.
Here is the trace of my console

I found that the crash only happens if the zoom level is higher than 1:1, for noise reduction I go up to 200% or more.

Thanks. If the program gets killed by the OS, there’s nothing gdb can do… however, maybe you are simply running out of memory?
What are the values here?:

If they are zero, can you try setting them to a small positive value and see if that helps?

They are at zero (automatic)
I’ll do some tests with positive values, I’ll come back later

With ART 1.16.3 I tried different values, the OS kills the process every time the memory is saturated.

With version 1.16.4 I can’t reproduce a crash, the memory occupation goes up to ~75% but not more!
Have there been any commits since then that could influence?

I usually build with a custom memory allocator (mimalloc specifically), but it seems I forgot to do that with 1.16.3. So it might just be that 1.16.4 is more memory efficient because of that :slight_smile:

Great, :+1: so I can consider my problem solved.
Thanks for everything and for the work you do.

Thanks to this thread i just realized that i forgot to re-enable mimalloc for art-rawconverter after Alberto added support for mimalloc 2.0 - will be fixed in the new package.

No problem, but thanks for your reactivity :clap: