Build for Windows, help please [SOLVED]


Yes, you’re right, didn’t think about that.
Build instructions do not say anything about which shell to use.
I also had to fix lensfun as you suggested.

Finally, I managed to build Darktable.

Thanks a lot !



The current lensfun in the MSYS2 depo has been built with the previous Python, hence it does not work with Python 3.7. Should be rebuilt…
I’ll add to the build.txt that one should use the MSYS2 shell to install packages and MINGW64 shell to build darktable, sorry if that is missing.



Hello MarcoNex,
I am not smart enought to do it by myself but
can I ask you to share your darktable for windows built?
Thanks in advance.



Here it is

I can’t guarantee it will work for you.
If you have a previous version of DT, make sure you backup your darktable folder in APPDATA
I had instability issues when converting a database from 2.6, while a fresh, clean install was OK-ish.
Look & Feel is not 100% good as I didn’t figure out how to install roboto fonts in MSYS2.

So, use it at your own risk.

1 Like


Isn’t it sufficient to install the required fonts in Windows and then select it in the application?
That’s how it works in Rawtherapee.
To install a font, double click on it and select install.



Thank you for sharing the build. It works successfully for me.
I have no problem with roboto font just installed it to Windows 10.



Where did you download the roboto font from ?
How did you configure DT to use roboto ? I could find any way to set the GUI font in the preferences.


(Todd Prior) #18

Link posted on FB page

Works for me on Win10



I followed the instructions here . They seem to make it no obvious to download. Once downloaded extract from the ,zip and install like other fonts.
To use the font you need to change the theme to “darktable-elegant” at the top of the GUI Options.


(Silvio) #20

Thanks a lot indeed!
Just tested on Windows 10 (home edition).
No crash whatsoever so far! :slight_smile:
Here is the screenshot (darktable-elegant theme):



@MarcoNex Thank you for the build!!


(Todd Prior) #22

Update this one works on my PC with Windows 10 Home…tried on my other PC that is Win10 Pro and it does not work…could also be completely unrelated I get an app failed to open 0xc0000142 error…



I found that some items were missing in the build process (instructions are not very clear…).
I will post an updated build soon, be patient



Here is a new build, fixed some missing components.
it looks much more stable, at least for me.

To fully enjoy the new GUI:

  • from Google, install the Roboto font family, including Roboto Condensed
  • in C:\Program Files\darktable\share\darktable\themes, replace the file darktable-elegant.css with this one
  • in Darktable preferences, select the theme Darktable Elegant

Please backup your old darktable folder in APPDATA before trying a potentially unstable version.
I won’t take the blame if you don’t :wink:


1 Like


Once again thanks for the build.
I will need to start looking at the css to change it to my liking. Not sure Roboto font is to my liking, but that is it great thing about the change to a css theme.


(Todd Prior) #26

Thanks for this Marco…looks like OPENCL is crashing it from what I can see in the error logs…I will see if it can be run with that disabled…



OpenCL seems to work for me.
Does DT crash at startup or later ? Did you use the last build ?


(Todd Prior) #28

Ya I now get unhandled exception at startup…what version of Windows are you running?? Here is the back trace I get…darktable_bt_6NQI0Z.txt (4.7 KB)


(Todd Prior) #29

This PC is Win10 Pro but it only has Intel integrated graphics so no openCL issue with this one . On my other PC also WIn10 Pro I have an NVidia Card. It seemed to crash on startup with an OPENCL init error. Then i ran it disabled and it went further but had a new error in libdarktable.dll…something about the ui widget…Most errors are referring to libdarktable.dll…THanks for posting a new build…likely my hardware or Win10 Pro maybe??



I have Windows 10 Home, version 10.0.17134, with nVidia 1060.
With the new build I only have some obscure GTK warnings about the GUI, but no crashes so far.
OpenCL is activated.
Does the official DT 2.6.2 windows build work ok for you ?
I’m afraid my knowledge of DT code is far too little to debug this…