Can get it IN, Can't get it OUT: RawTherapee keeps crashing

rawprocessing

(Frank Valdez) #1

Hi,

New to RawTherapee.

It keeps crashing, shutting down when I try to process my edits.
I’ve researched previous threads and none of the previous solutions have worked for me.

RawTherapee Version: 5.0-r1-gtk2
Branch: 5.0-r1-gtk2
Commit: 1077c4ba
Commit date: 2017-02-01
Compiler: gcc 6.3.0
Processor: pentium4
System: Windows
Bit depth: 32 bits
Gtkmm: V2.24.4
Build type: release
Build flags: -m32 -mthreads -march=prescott -std=gnu++11 -march=pentium4 -Werror=unused-label -fopenmp -Werror=unknown-pragmas -mwindows -DNDEBUG -msse2 -mfpmath=sse -O3
Link flags: -m32 -mthreads -static-libgcc -Wl,–large-address-aware,–verbose -march=pentium4 -mwindows -s -O3
OpenMP support: ON
MMAP support: ON

System information:
Windows Vista Home Basic, Dell, Intel® Core ™2Duo CPU T5850 @2.16GHz 2.17 GHz, 3582 MB, 32-bit Operating System

Downloaded from: http://rawtherapee.com/downloads

(not sure, downloaded abt 2 weeks ago, this link was highlighted). Just dowloaded and reinstalled it again.

What’s happening:
Apply the “Neutral” processing profile
Exposure adjustment, crop adjustment
Apply "Pop Skin 3"processing profile
Exposure adjustment
Add to queue
Edit other photos
When there are about 8 or 9 in queue, go to queue section and click “start processing”.
Error Message 1
Turns White
Error Message 2
Crashes

When I reopen RawTherapee, my queue remains the same 8 pics, just unprocessed.

It’s frustrating because I can get the pic just like I want it IN Rawtherapee but I just can’t get it OUT of RawTherapee.

Here’s some screenshots of what’s going down http://imgur.com/a/YhNl8

Solutions that have NOT worked so far:

  1. I reinstalled a new version of RawTherapee.
  2. I deleted the appdate/cache/images file. Wasn’t sure if I should also delete appdate/cache/aehistograms or appdate/cache/data so I’ve left them alone for now.

(Ingo Weyrich) #2

As you use RawTherapee on 32bit Windows, you should read this: http://rawpedia.rawtherapee.com/The_Floating_Point_Engine
Especially the Use 4-Gigabyte Tuning in Windows part


(Morgan Hardwood) #3

Hello @Frank_Valdez

First, let me congratulate you on a good report! I wish all reports provided all the required info as you did :slight_smile:

Low RAM is the most likely culprit - follow @heckflosse’s advice.

By the way, what camera model are you using? It’s important because it will tell us what size the raw image is, which tells us how much RAM it would need.