Cannot install libpango dependency


#1

Hi,

I am trying to install gimp-git and I am getting the error:

- Error: missing dependency pangocairo >= 1.42.0 and pangoft2
    *** We require Pango with the optional support for Cairo compiled in.  

I am trying to install dependency libpango by installing libpango-1.0-0_1.42.1-1_amd64.deb. When I open the .deb package using GDEBI I get the following error:

"Error: Dependency is not satisfiable:gir1.2-pango-1.0-0(=1.42.1-1)

What should I do to satisfy this dependency? Should I download gir1.2-pango-1.0-0(=1.42.1-1) ? Where can I find it?

I am just plain lost with this pango dependencies.

Thanks

OS: Xubuntu 18.04 - 64 bit.


#2

You probably don’t want to install .deb files manually. Instead use your distribution’s package manager to install the library together with all the dependencies. Something like sudo apt install libpango1.0-dev should do the trick.


(John Titor) #3

I get the same error:

– Error: missing dependency pangocairo >= 1.42.0 and pangoft2
*** We require Pango with the optional support for Cairo compiled in.

However i do have these packages installed using apt:

  • libpango-1.0-0 (1.40.14-1ubuntu0.1)
  • libpango1.0-dev (1.40.14-1ubuntu0.1)
  • libpangocairo-1.0-0 (1.40.14-1ubuntu0.1)
  • libpangoft2-1.0-0 (1.40.14-1ubuntu0.1)

Am I missing any Pango/Cairo related packages or should I compile Pango from source?

Thx!

OS: KDE Neon (based on Ubuntu 18.04)