Cannot start DT after upgrade to Ubuntu 22.04 from 20.04

Everything was working fine with Ubuntu 20.04.
I think problem with amdgpu driver amdgpu-install_22.20.50200-1_all.deb as I can open darktable without OpenCL. My graphics card is AMD RX-570

darktable -d all output related to OpenCL

> [opencl_init] opencl related configuration options:
> [opencl_init] opencl: ON
> [opencl_init] opencl_scheduling_profile: 'default'
> [opencl_init] opencl_library: 'default path'
> [opencl_init] opencl_device_priority: '+1/!1,*/+1,*/+0,*/+0,*'
> [opencl_init] opencl_mandatory_timeout: 200
> [opencl_init] opencl_synch_cache: false
> [opencl_init] opencl library '' found on your system and loaded
> Abort was called at 39 line in file:
> ./shared/source/built_ins/built_ins.cpp
> Aborted (core dumped)

Please help me as I am absolutely new to Linux and I have searched the net and found that there is some problem with ROCm and enabling OpenCL on Ubuntu 22.04

I will not be of direct help for you, as I am not involved in Ubuntu, but from aside I remember, I saw something like this already, so you are not alone. Be patient and Google as well :slight_smile:

Maybe @Jiyone remembers? But I might be wrong…

I teach DT to students and one of the students on his windows computer enabled OpenCL and his DT crashed every time he tried to start editing am image. I lent him my computer for the first class and then at the end of the class I stumbled upon disabling OpenCL and his DT works fine now. I don’t understand the technical reason, but I believe some systems will not work with OpenCL activated.

I remember (but can’t remember when and where) some issues with some OpenCL AMD drivers. Probably that. Would be good to test with older version of AMD or use darktable without OpenCL until next update of AMD drivers and test again OpenCL enabled after that.

OpenCL Is better since times with Nvidia card than Intel or AMD, unfortunately (and I only have Intel card: Neo drivers have been hugely improved recently).

I have the same GPU and 1 year ago I couldn’t install amgpu-pro on ubuntu 22.04 because opencl driver was not compatible with that version of ubuntu.
I also had to run a script to be able to install it.

I have not tried since.

This library file is from previous driver and causing problems. How can I remove this file?

Can you please guide me how to unable opencl on amdgpu on 22.04? Which is the script?

If nothing else helps, the best option is probably to start darktable with

darktable --disable-opencl

By default, OpenCL support is activated in darktable if all the above steps were successful. If you want to de-activate it you can do so in preferences > processing > cpu/gpu/memory. This configuration parameter is grayed out if the OpenCL initialization failed.

I have installed amd & intel drivers without any errors but
clinfo and darktable -d all gives me the following error

Abort was called at 39 line in file:
Aborted (core dumped)

sudo lshw -c video shows
description: VGA compatible controller
product: Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
vendor: Advanced Micro Devices, Inc. [AMD/ATI]
physical id: 0
bus info: pci@0000:01:00.0
logical name: /dev/fb0
version: ef
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom fb
configuration: depth=32 driver=amdgpu latency=0 mode=3840x2160 resolution=3840,2160 visual=truecolor xres=3840 yres=2160
resources: iomemory:200-1ff iomemory:210-20f irq:161 memory:2000000000-20ffffffff memory:2100000000-21001fffff ioport:e000(size=256) memory:f7e00000-f7e3ffff memory:c0000-dffff
description: Display controller
product: CoffeeLake-S GT2 [UHD Graphics 630]
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm bus_master cap_list
configuration: driver=i915 latency=0
resources: iomemory:3f0-3ef iomemory:3f0-3ef irq:163 memory:3ffe000000-3ffeffffff memory:3fd0000000-3fdfffffff ioport:f000(size=64)