Can't download G'MIC

Good evening,
I have been trying to download from the G’Mic sight (redirected to FossHub), and it keeps giving me an HTTP 403 error with Internet Explorer and a the following error with Chrome:

This XML file does not appear to have any style information associated with it. The document tree is shown below.

AccessDenied tx00000000000014b8b1ac5-005d6d13c2-23e283-sfo2a 23e283-sfo2a-sfo

Any help would be appreciated.



It works for me on Firefox mobile. Perhaps try again a but later?

I just tried and it appears to be working? @FossHub might know if something is strange in their system, but it might have been a temporary glitch and things seem to be running fine now. Try again?

Confirmed. I get this

on Firefox (win10).


Sorry for the late reply! I just tested the download from multiple locations and browsers. For me, it worked. From the error message, you posted this appears to be a POP problem with the CDN that was serving the downloads.

We just made some changes a few seconds ago. Please refresh the page and try to download again.

Thank you!
FossHub Team

1 Like