Can't get Nikon Z9 working with darktable master [Solved]

@kmilos At the weekend I upgraded my system from Fedora release 36 to 37. Darktable stopped working due to dependncy changes. I found I could not fix that easily, so I tried installing 4.0.1 from the fedora repo, in the hope that I could just edit the cameras.xml file. That doesn’t work (cant read whitebalance message). So I removed it and did a clean install from git master. Clean install compiles OK. I edited cameras.xml with the change recently merged to the develop branch of rawspeed. Now I don’t get any error message, but darkroom just displays an all white picture.

Any suggestions please?

No idea, but seem to remember the all white image seems to be related to black/white levels in the rawprepare module…

Hm. Clicking throught the history from the bottom:

  1. Original shows a reasonable (but not white balanced) photo
  2. Raw black/white point shows an all black image
  3. This remains the same until reaching …
  4. highlight reconstruction, which displays an all white image

Hovering over the history item for Raw black/white point
All four black levels are displayed as 1008 → 0.
Whitepoint is displayed as 15982 → 0

If I look at photos developed prior to the weekend (on Fedora 36), they look OK. Hovering over any module in the history stack doesn’t show anything though.

I just installed the last WIndows nightly 4.1.0+1081~g956b53c9c, added the relevant entry to cameras.xml, and cleaned out my config folder. The RPU sample imports without a hitch:


So perhaps there’s something in your config/presets/edit history? Can’t help w/ those I’m afraid…

Starting with a new empty .config/darktable directory doesn’t help (only difference is that raw black/white point module now shows white instead of black).

So I have checked cameras.xml and it has . For some reason this is getting overridden.
I did some reset ing on this module, then reset the history. Looks fine now.