Can't print borderless with darktable

I’ve just got a new printer (Canon iP8750) and I’m getting familiar to printing my pictures.
As the title suggests, I was not able to print borderless with darktable.

I’m on Ubuntu 20.04, with darktable installed from OBS (v 3.4.0), and installed the driver for Ubuntu provided by Canon.
In GIMP it seems everything works fine, in darktable I can’t see what I’m missing, in case I am missing something.

You can see here below a snap from my phone of the two prints: on top is what I could print from GIMP (what is expected), on the bottom is what I could get from darktable.

The printing options in GIMP look alright:

In darktable the settings have a different look, and I couldn’t find anything clearly stating “borderless”, so I guessed for the ‘4x6.bl’ in the papersize menu.

One thing that suggests something wrong is that the states paper size is smaller (the GIMP settings tell the truth).
I tried also the other 2 available ‘4x6’ options in the paper size menu (no indication about what’s different…) with worse results.

So, has anybody an idea where I should head next?
In GIMP it worked out of the box, so I’m covered for my basic printing needs, but I’d prefer to print directly from darktable.

Thanks in advance for your time.

(All pictures in this post are released under CC0 license)

This may not work…Sorry I don’t print from DT as I am on windows but what if you use the framing module and specifically set the border to 0%…maybe that will force it to print poperly??? Just a guess Also your left right bottom and top are set to -5 should they be zero as they are in gimp…

Thanks for your suggestion.
Actually, they were set to 0 when I printed for real (the screenshot was just taken afterwords, I didn’t check all the settings…). Anyhow, changing the margins doesn’t change the paper size (highlighted in the screenshot), and it’s always not the correct one.
By the way, I also tried changing those margins to negative values for real prints. The picture is printed “zoomed in” but the white margins are still there.
It seems to me that darktable doesn’t have the proper printer settings, or at least, it has different ones than GIMP (and all other software on the PC).

As for the framing module… I don’t know what you refer to.

Yes it’s really a problem between darktable and your printer.
The correct borderless paper size is not sent to the printer, and so the printer does not do switch to the correct process.
In that case, you’re probably better to export the image as TIFF, print from another soft, and report a bug to https://github.com/darktable-org/darktable/issues :wink:

1 Like

A hunch is that darktable might not read the same list of available papers. I can’t remember if it comes from the printer driver or separate paper config files that set things as size and margins. I have a vague memory from way back that paper sizes need their own config file somewhere.

There is a module called framing…it can be used to apply borders to your pictures…

Ah yeah ok I see.
Well, that must not affect the printing (it just manipulates the image itself, by “painting” borders). If this module would affect the printing, this would be a different new bug, I suppose.

Thanks for your input, though.

I was just grasping at straws as I could not test it. I was just wondering if adding the border (frame) with a setting of 0% might have caused the print module to behave in a way that it would give you borderless printing…hopefully you get it sorted

1 Like