Color wrong with Neutral profile

Hi everyone,
I’m using rawtherapee 5.0-r1 on Fedora 25 but even though in the thumbnail view I see correct color of photos, when I double-click on a photo to open it, the colors are completely wrong. I’m using the “Neutral” profile as default. I have try to copy all profiles files from a Windows PC but nothing change. I would like that the opened photo be as similar as possible to the original color.
I remember that all was OK in Fedora 24 and previous versions.
Thank you for any suggestions.

@Alberto_Bertoncini please upload a sample raw file. Use https://filebin.net/ if you cannot directly attach one here.

What camera model?

My camera is Canon 450D but also with Canon 6D raw files is the same.
Anyway all files have the same behaviour/colors.
All is OK with Ufraw and the same files.
Here a sample raw file.

IMG_21139.CR2 (13.3 MB)

It works in RT 5.0 stable and in the current dev branch no problem https://i.imgur.com/o2SNDfC.jpg
That means user error. Check your monitor profile, ensure that you’re really using “(Neutral)” by applying it, don’t crop screenshots.

Which SO do you use? Linux? Fedora? I have tried on windows the same photos and all is OK. Therefore I also think that should be an user problem. Today I have deleted all the folder “rawtherapee” in my home, just to avoid that some old setting causes wrong behaviour, but nothing is changed.
Can you upload your .pp3 file, so I can compare it with mine and try it?
Attached, the one generated with my configuration.

IMG_21139.CR2.pp3 (9.2 KB)

Everything looks fine here with your pp3 and the latest dev version of RawTherapee (I don’t have 5.0 to try here).
Perhaps you have a weird color profile selected for your monitor?

I never calibrate my monitor with Fedora 25, neither with the previous version of it. I tried some of the monitor profiles included with F25. Attached, the color profiles I’m using. I have tried also the Adobe one or SyncMaster but all is the same. For all other programs, colors are good (Gimp, photo viewer, others…)

Version 5.0 of RT doesn’t automatically apply the system color profile (the upcoming version 5.1 will). You have to explicitly select the default profile under “Preferences -> Color Management”. Can you check that this is set as sRGB?

It doesn’t matter.

No need, use “(Neutral)”.

Do this:

  1. Delete your “options” file,
  2. Download and open this photo https://raw.pixls.us/getfile.php/1353/nice/Canon%20-%20EOS%20450D%20-%20RAW%20(3:2).CR2
  3. Apply (Neutral),
  4. Take a screenshot of the whole RT window (Editor tab) and show it here.

I did some test today:

  1. Deleted options and Neutral to the raw file you sent.
    Same test as root but all is the same.

  1. I’ve tried to use the same icc used by the monitor but nothing change.

  1. I have opened the .CR2 file with my laptop (Debian) and rawtherapee version 4.2-1, using the laptop monitor and the external monitor (SyncMaster) and in both cases all is OK (whithout any icc in rawtherapee).

Tomorrow I would like to try to upgrade RT on Debian and do the same test with the external monitor.

Thanks for suggestions.

@Alberto_Bertoncini could you set the profile fill mode to “fill”, i.e. change this into this , then apply neutral again and take another screenshot? Also, after applying neutral, save the image, and upload both the screenshot and saved image using https://filebin.net/ (please don’t attach them here as that might destroy some metadata).

I apologize for the delay in replying but I had some day full of things to do.
In the meantime I have done the test with Debian and RT 5.1 with the same monitor, and all was OK. Therefore I think that some in my Fedora configuration don’t work correctly.
Anyway I tried to follow your suggestion but I can’t find the “profile fill mode” on RT, is it in the “color Management” TAB? Unfortunately I can’t see the pictures you posted, they are very little…
Probably tomorrow or next week I will change my PC, installing a completely new Fedora, due to the new 64bit Cpu. I hope that this will solve my problems.
I hope to close this topic with a good news!
Thanks

Ah OK, now I understand! ;-p
Here the screenshot after apply the fill mode to fill+Neutral and the pp3 file.
“save the image” means JPG/TIFF exported? The CR2 file should be the same as the original…(?)

pp3 file:
https://filebin.net/2g2t15bb3mgig0mx

Thanks @Alberto_Bertoncini . By now we’ve established that the most likely cause of this problem lies outside of RT.

Hello everyone!
After bought the new PC, I’ve installed a fresh Fedora release (64 bit), and I can confirm that, as you said, the problem was outside RT: the new SO solved finally my problem. Unfortunately the old SO is in the same drive of the new F25-64 therefore i can’t try it again. The important thing is work with RT again.
Thanks to all.