Compiling error GMIC


(Gabriele ) #1

Hi All,
upgrading my distro (Slackware 64 current) I saw I have Gimp 2.10.8 :smiley:
I installed it and I tried to compile GMIC a new time.

When configuring I have:

CMake Warning (dev) at CMakeLists.txt:83:
Syntax Warning in cmake code at column 97

Argument not separated from preceding token by whitespace.
This warning is for project developers. Use -Wno-dev to suppress it.

– The C compiler identification is GNU 8.2.0
– The CXX compiler identification is GNU 8.2.0
– Check for working C compiler: /usr/bin/cc
– Check for working C compiler: /usr/bin/cc – works
– Detecting C compiler ABI info
– Detecting C compiler ABI info - done
– Detecting C compile features
– Detecting C compile features - done
– Check for working CXX compiler: /usr/bin/c++
– Check for working CXX compiler: /usr/bin/c++ – works
– Detecting CXX compiler ABI info
– Detecting CXX compiler ABI info - done
– Detecting CXX compile features
– Detecting CXX compile features - done
– Using CMake version: 3.13.0
Building for target host application: gimp
G’MIC path: …/gmic/src
Found G’MIC repository
Found …/gmic/src/CImg.h
Found …/gmic/src/gmic_stdlib.h
CImg version is [242]
G’MIC version is [242]
– Found ZLIB: /usr/lib64/libz.so (found version β€œ1.2.11”)
– Found PNG: /usr/lib64/libpng.so (found version β€œ1.6.35”)
– Found PkgConfig: /usr/bin/pkg-config (found version β€œ0.29.2”)
– Found FFTW3
– FFTW Found Version:
– Found CURL: /usr/lib64/libcurl.so (found version β€œ7.62.0”)
– Found OpenMP_C: -fopenmp (found version β€œ4.5”)
– Found OpenMP_CXX: -fopenmp (found version β€œ4.5”)
– Found OpenMP: TRUE (found version β€œ4.5”)
G’Mic: using OpenMP
– Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so
– Looking for XOpenDisplay in /usr/lib64/libX11.so;/usr/lib64/libXext.so - found
– Looking for gethostbyname
– Looking for gethostbyname - found
– Looking for connect
– Looking for connect - found
– Looking for remove
– Looking for remove - found
– Looking for shmat
– Looking for shmat - found
– Looking for IceConnectionNumber in ICE
– Looking for IceConnectionNumber in ICE - found
– Found X11: /usr/lib64/libX11.so
Release build
– The following OPTIONAL packages have been found:

  • PkgConfig
  • CURL
  • OpenMP, A low-level parallel execution library, http://openmp.org/wp/
    Optionally used by gmic-qt
  • X11

– The following REQUIRED packages have been found:

  • Qt5Core
  • Qt5Gui
  • Qt5Widgets
  • Qt5Network
  • Qt5 (required version >= 5.2.0)
  • Qt5LinguistTools
  • PNG
  • ZLIB
  • FFTW3

– Configuring done
– Generating done
– Build files have been written to: /root/git/gmic-qt/build

It seems correct, but when I compile I have:

…
[ 85%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/PreviewWidget.cpp.o
[ 86%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/ProgressInfoWidget.cpp.o
[ 88%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/InOutPanel.cpp.o
[ 89%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/ZoomLevelSelector.cpp.o
[ 90%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/SearchFieldWidget.cpp.o
[ 91%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/LanguageSelectionWidget.cpp.o
[ 92%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Widgets/ProgressInfoWindow.cpp.o
[ 94%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/root/git/gmic/src/gmic.cpp.o
[ 95%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/src/Host/Gimp/host_gimp.cpp.o
[ 96%] Building CXX object CMakeFiles/gmic_gimp_qt.dir/gmic_gimp_qt_autogen/mocs_compilation.cpp.o
In file included from /root/git/gmic-qt/build/gmic_gimp_qt_autogen/mocs_compilation.cpp:2:
/root/git/gmic-qt/build/gmic_gimp_qt_autogen/3ITBSYFC75/moc_InOutPanel.cpp:9:10: fatal error: …/…/…/…/…/sorgenti/git/gmic-qt/src/Widgets/InOutPanel.h: No such file or directory
#include β€œβ€¦/…/…/…/…/sorgenti/git/gmic-qt/src/Widgets/InOutPanel.h”
^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make[2]: *** [CMakeFiles/gmic_gimp_qt.dir/build.make:1038: CMakeFiles/gmic_gimp_qt.dir/gmic_gimp_qt_autogen/mocs_compilation.cpp.o] Error 1
make[2]: *** Waiting for unfinished jobs…
make[1]: *** [CMakeFiles/Makefile2:73: CMakeFiles/gmic_gimp_qt.dir/all] Error 2
make: *** [Makefile:130: all] Error 2

The file is there

root@darkstar:~/git/gmic-qt/src/Widgets$ ls
InOutPanel.cpp LanguageSelectionWidget.cpp PreviewWidget.cpp ProgressInfoWidget.cpp ProgressInfoWindow.cpp SearchFieldWidget.cpp ZoomLevelSelector.cpp
InOutPanel.h LanguageSelectionWidget.h PreviewWidget.h ProgressInfoWidget.h ProgressInfoWindow.h SearchFieldWidget.h ZoomLevelSelector.h

Can anyone help me ?? :blush:


(G'MIC staff) #2

Not sure what is happening. But would it be related to the fact you are trying to compile as root, while your files are stored in your user $HOME sorgenti ?
Maybe the compiler does not consider the include PATH correctly if the compilation is done this way.


(Gabriele ) #3

Hi David,
I do not know what is happening, too.:hushed:

I’m compiling as root under /root…Where do you see I’m in $HOME??

I have anothe pc with the same distro and all is OK.
I think it could be something tied to the configuration… I’m investigating…


(Gabriele ) #4

Hi David,
I re-compiled as normal user and all worked.
Cheers

Gabriele