darktable 2.4.2 in Windows not Exporting

darktable

#1

Hi! I was previously able to export images in 2.4.1, but now after using 2.4.2, will only export randomly. It is saying unhandled exception occured & writing backtraces. I am exporting jpg & have tried Tiff, but neither will properly export. It also says something about ‘shadhi?’ sometimes & will export 1 & then says its unhandled the next time. I have no clue what to do about it, but liked using darktable up to this point, so hopefully somebody knows what to do?


(Mica) #2

Please post the backtraces!


#3

Okay… here they are. I think. Not very familiar with this so hopefully what you mean?

darktable_bt_YRJRGZ.txt (8.7 KB)

Another

darktable_bt_HE72GZ.txt (6.8 KB)


(Mica) #4

I believe that’s it, thanks. First thing I check when windows troubleshooting is to make sure the antivirus software isn’t interfering with things. Can you do that please?


#5

I don’t run any except whatever is built into Windows. What am I looking for?


(Mica) #6

You want to make sure there is an exception for darktable in Windows Defender.


#7

Okay! Was not allowed, now is allowed. Tried to export, still the same.


#8

And how does that change affect your exports?


#9

Still doing the same thing, unfortunately. Unhandled exception… writes backtrace.


#10

@Marli: could you share the image in question and the XMP file ? Based on the first backtrace it seems to be a problem with the Framing module.
The second is more difficult, I have no good idea yet,


#11

I 1st encountered it with a photo I put a frame on & wondered if it is the frame module causing it. It did export as Tiff, but after testing it, won’t export randomly. I checked the memory & it stays at about 1/2 whether it exports or not. Anyway, resized pic & xmp below. (Original was 6000x4000) The frame is wide White with grey line, not quite showing in pic for me except along the left side.

DSC_0041_03.NEF.xmp (9.3 KB)