Darktable 2.7 (dev) Windows builds

Drag and drop the PDF onto the edit post window or click the “upload arrow” button at the bottom right of the edit window.

New build darktable-2.7.0+1662~g6f78ef096-win64 with working snapshots has been just added.

9 Likes

Hi,
many thanks ! The snapshots works perfectly.

Many thanks for this !!

Many thanks again for sharing the Windows build.

Many thanks for sharing the latest build. I have occasional crashes while creating masks using ‘C’ option. Snapshot is working fine.

Many thanks for sharing!!
I downloaded the …+1477 version and after installing it my antivirus doesn’t let it run because for unauthorized file encryption activity. What can i do apart from adding and exception in antivirus list?

If you have Windows 10 and the last updates and if you activated some of the new ‘privacy’ settings, you might need to give darktable explicitly the permission to access various folders on your computer. Look here for more details: https://www.windowscentral.com/how-manage-file-access-permissions-apps-windows-10-april-2018-update

Wow, I just downloaded the 2.7 and is so much faster than the 2.6.2 version! Thanks for sharing.
First time it did run fine but now can’t activate OpenCL:

C:\darktable\bin>darktable-cltest.exe
0.079951 [opencl_init] opencl related configuration options:
0.081950 [opencl_init]
0.082950 [opencl_init] opencl: 1
0.084948 [opencl_init] opencl_library: ‘’
0.086947 [opencl_init] opencl_memory_requirement: 768
0.089945 [opencl_init] opencl_memory_headroom: 300
0.092943 [opencl_init] opencl_device_priority: ‘/!0,//
0.095941 [opencl_init] opencl_mandatory_timeout: 200
0.097940 [opencl_init] opencl_size_roundup: 16
0.099939 [opencl_init] opencl_async_pixelpipe: 0
0.102937 [opencl_init] opencl_synch_cache: active module
0.104935 [opencl_init] opencl_number_event_handles: 25
0.107934 [opencl_init] opencl_micro_nap: 1000
0.109932 [opencl_init] opencl_use_pinned_memory: 0
0.110932 [opencl_init] opencl_use_cpu_devices: 0
0.112931 [opencl_init] opencl_avoid_atomics: 0
0.114930 [opencl_init]
0.117928 [opencl_init] found opencl runtime library ‘OpenCL.dll’
0.119927 [opencl_init] opencl library ‘OpenCL.dll’ found on your system and loaded
0.205873 [opencl_init] found 1 platform
0.207872 [opencl_init] found 1 device
0.209871 [opencl_init] device 0 Ellesmere' supports image sizes of 16384 x 16384 0.212870 [opencl_init] device 0Ellesmere’ allows GPU memory allocations of up to 3264MB
[opencl_init] device 0: Ellesmere
GLOBAL_MEM_SIZE: 4096MB
MAX_WORK_GROUP_SIZE: 256
MAX_WORK_ITEM_DIMENSIONS: 3
MAX_WORK_ITEM_SIZES: [ 1024 1024 1024 ]
DRIVER_VERSION: 2906.10
DEVICE_VERSION: OpenCL 2.0 AMD-APP (2906.10)
0.540668 [opencl_init] options for OpenCL compiler: -cl-mad-enable -DAMD=1 -I"C:\darktable\share\darktable\kernels"
0.544665 [opencl_init] compiling program demosaic_ppg.cl' .. 0.547664 [opencl_load_program] loaded cached binary program from fileC:\Users\Moises\AppData\Local\Microsoft\Windows\INetCache\darktable\cached_kernels_for_Ellesmere_290610\demosaic_ppg.cl.bin’
0.554660 [opencl_load_program] successfully loaded program from `C:\darktable\share\darktable\kernels\demosaic_ppg.cl’
0.558656 [opencl_build_program] could not build program: -11
0.560657 [opencl_build_program] BUILD STATUS: -2
0.562654 BUILD LOG:
0.563653 Error: The binary is incorrect or incomplete. Finalization to ISA couldn’t be performed.

0.566651 [opencl_init] failed to compile program `demosaic_ppg.cl’!
0.570649 [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
0.572648 [opencl_init] initial status of opencl enabled flag is OFF.

Why does Avast complain about libgio-2.0-0.dll?
When I use a file from Gimp 2.10.12 - it doesn’t report a problem.
How to add Olympus support?
How to show the entire “more modules” menu?
0%20libgio

You can try to delete the content of the folder:
“C:\Users\Moises\AppData\Local\Microsoft\Windows\INetCache\darktable\cached_kernels_for_Ellesmere_290610”

And restart darktable. Let me know your experience.

1 Like

That’s work, but I have to delete de folder every time I start Darktable, because in a second run the Opencl become unavailable.

Has anyone else experienced crashing with the latest two builds? Specifically when when clicking import > folder in the lighttable.

I did, for instance when I’m working in DT and then I click on Lightable.

I encountered no problem in importing an folder with raw and jpg files using the latest darktable 2.7 version on windows 10 platform.

I’m experiencing crashes on the latest build when using masking. No error message or anything, DT just disappears.

I get this at work with trend micro…when it goes to interact with updating thumbnails I get the same error and DT binary is quarantined…

I actually did get the log file
darktable_bt_C4437Z.txt (11.0 KB)

Same thing for me…tend micro installed in the work notebook

Same here, mine is crashing when I use masks as well. However, it’s not all the time though. Just occassionally. Especially when I use the sliders.