darktable crashes after WIndows 10 update

Hi, I’m running darktable on Windows 10. I’m using OpenCL.

All was working OK yesterday. I allowed Windows 10 to update overnight, and this evening I get an an unhandled exception error when starting darktable.

Any ideas how I can fix this please? Thanks, Paul

Backtrace file attached

darktable_bt_LW1E20.txt (7.0 KB)

Please try disabling OpenCL.

I run darktable on Windows 10, and OpenCL locks up my system without even writing a backtrace. Try disabling OpenCL and see if that’s any better

Many thanks - running darktable from the command line with opencl disabled works…

But - although I started it in the Windows directory where the darktable database and library files are, darktable opens with no images displayed. Any ideas on what I need to do next please so that I don’t have to re-import all my RAW files?

You should be able to specify the location of your configuration files by adding the following to your command line: --configdir “C:\Users\user name\AppData\Local\Darktable”

Or where ever and how ever your config files are located. Be sure to use the precise syntax

Yes - that worked, brilliant! I guess that is probably in the manual somewhere so I should have spotted that myself.

I remembered that last time this happened (November 2020) I managed to fix the issue by rolling back the Intel video card driver which had been updated as part of the Windows update. This time it looks like the Intel HD Graphics 630 card driver was updated to version Sadly, the option to roll back driver isn’t available now. The previous version that worked OK was

Many thanks.

Maybe just flush the cache of pre-computed OpenCL kernels after an update.

Thanks for the suggestion.

I decided to check the Intel website for graphic card drivers, and it turns out that there was a later version available ( - I installed that, and now all is fine! Very pleased!!

[It has also fixed the same issued with GIMP not loading at all.]