darktable as raw handler for gimp

I use darktable for raw file processing and after closing the file is imported (normally .EXR file) in Gimp, what worked always

now “out of nothing” it is not working anymore, Gimp pops up with

Execution error for procedure ‘gimp-file-load’:
Unknown file type


Opening ‘/home/hm/__ZFOTOS/_temp_dir_738/SAM_8984.SRW’ failed: Raw Samsung SRW plug-in could not open image

and same with Sony raws

Opening ‘/home/hm/__ZFOTOS/_temp_dir_712/DSC05641.ARW’ failed: Raw Sony plug-in could not open image

this is on Arch Linux, all deps are met, both programs work normally with anything else, I have changed something in mime types before, but I don’t remember what, because I think I have reset it after, but I might be wrong about it and was not related to this file types

darktable v.4.2.1-1
gimp v.2.10.34

somebody knows where I should looking for what?


What else has changed recently on your system?

well, there are constant changes like upgrades but nothing what could be related, or I don’t know that it is, I never went into this darktable <-> gimp thing because it always worked for me
I know that something must have been changed, I just can not say what it may be

well, the problem is Gimp 2.10.34 from arch repo, the file-exr plugin is bad, I picked the 2.10.32 file-exr and it is working

1 Like