Darktable desktop icon, when installing from source

From the github README:
"If you want to have dartkable displayed along your other applications, you only need to add a symbolic link:

ln -s /opt/darktable/share/applications/darktable.desktop /usr/share/applications/darktable.desktop"

I did this. It works - sort of. The icon displayed is the system’s default icon, not the darktable icon.

Is there some other step necessary to enable gnome to find the icons?

Open darktable.desktop in a text editor and search for icon then make sure the path to the icon is correct. Perhaps use the full path.

Thanks.
Specifying the full path works (needs a reboot).
I also edited ~/darktable/build/share/darktable/darktable.desktop.in, for protection against rebuilds.