darktable git master chormatic aberration bypassed

Hi, so I have this new lens, an M.Zuiko 12-45mm F/4. However, in darktable git master, when I try to activate chromatic aberrations, I see “bypassed” in the module and apparently it is doing nothing.
Why is that?


You might want to have a look at this:


1 Like

thanks. So basically this means that thereis no preview?

Yes, that is how I interpret it.

Maybe one of the devs can chime in and explain it a bit better/broader than it is done in the darktable docs.


darktable modules only operate on the area of the image that’s currently being viewed (makes processing of the centre image much quicker). Chromatic aberrations is one of those oddities that can’t work this way and it’ll therefore look wrong/misleading if it’s enabled when zoomed in. So better to disable it than mislead you.

1 Like

ok. so the preview was wrong with the old CA module as well?

Yes - the previous version just had a warning in the docs. See the old version of the user manual here.

1 Like

Exactly as Chris said, the pre 3.6 version lead to very bad results only when zooming in and people complained repeatedly about this. (When exporting everything was fine).

Unfortunately the algo works well only if large parts of the raw image data are used and because of technical reasons hidden in dt’s processing pipeline that couldn’t be fixed yet (hopefully i’ll find a solution for 3.8) At least you get a warning that CA is bypassed atm.

1 Like

maybe change the text to something more descriptive?

“Not applied while zoomed in”



If you hover over the message you should see a fairly descriptive tooltip

In fact i like darix suggestion as it is not so technical and explain the reason.

and we can not make the text descriptive to begin with? i am glad there is a tooltip … but why make the default so obscure?

fair enough - I was just making an observation :slight_smile:

1 Like