darktable Import problem

I am using dartktable 3.6 on Ubuntu Mate 20.04. I downloaded about 50 images using Rapid Photo Downloader to an external hard drive. My file system is Year/Month/day-job.

When I added the files to my library, half of the images were skulls. Also, when I tried to use my tags to look at older images, nothing is displayed, or a lot of skulls.

Is there a way to reset my search.

How do you mount your external drive? What version of darktable and how/where did you install from?

darktable 3.6 was downloaded from the dt website. My ext hard drive is mounted via usb-c

Do you use the mount command? Click it in the file manager?

I don’t know see a mount command.

I decided to remove files from the database.
I then re-imported a folder to the database which contains 6 folders.
Now if I try to use collections, nothing happens.
I’ve tried entering a tag (infrared), no change.
I’ve tried entering a folder, no change.
Is there a way to reset collections?
darktable 3.6

Its a bit hard to tell what is going on because you’re not describing things in enough detail.

I think I found a solution. When I clicked collections>folders(film roll) and uder the right down arrow to select , When I entered a tag/folder,etc,the db started acted normally.
Thank you