Darktable instance options all greyed out except rename

Hi,

Is anyone experiencing this?

image

image

Good evening, Rei!

No. I am on 2.7.0+1461, and it behaves normally.

Have fun!
Claes in Lund, Sweden

Thanks, Claes.

Well, I’m not sure I understand this but it seems it has to do with modules groups.
If none of the groups heading is highlighted, then the instance options are disabled (except rename):

image

If one of the groups is selected, then the options enable:

image

However, when the last active group heading is disabled again, the instance options remain enabled:

image

Not sure if I got the idea, but now the workaround seems to just click on one of the heading groups.

I have also noticed this behavior recently. Not sure what is the cause but it drives me nuts sometimes. Last time it went away after compressing the history stack. No idea if this was coincidence. I will check for @gadolf s assumption next time.

Hi @Thomas_Do, and @gadolf
Are your history stacks very large?

/Claes

Not mine:

I opened an issue:

1 Like

Not really, I compress quite often. But sometimes, when I switch between different modules and changes things serveral time in one of them, the history stack shows multiple items of this module, although there is only one. Compressing the history stack helps.

Just a side kick…
darktable --version gives you what it says :slight_smile:

image

Cool! Tkx!

EDIT: @AxelG This leads me to one question: it says that I have OpenCL support enabled. However, in the settings GUI, it shows disabled and greyed out. Why?

Because of this (fixed now)

1 Like

How did you enable Lua, especially with 5.0.2?
Mine says disabled

I don’t know what to say, I’ve never looked at that or tweaked anything.
I’m on Ubuntu 18.04.