darktable recent development build Windows 64

Thanks very much for the help.
I think I am nearly there, but when I try and build darktable I receive the following error:

bash: cmake: command not found

any thoughts on what I need to do. Thank you.


Install cmake on your system.

cmake should be installed with MSYS2.

I did install MSYS2 following the instructions in the darktable/build.md instructions, but something must have gone wrong with cmake.
Is there a way to just install cmake without going through the whole process again?
I am out of my depth so please feel free to elaborate with command line instructions. Thank you.

As mentioned earlier, you should switch to the MINGW64 terminal/subsystem when instructed. You might be trying to execute commands in the MSYS2 terminal still, where cmake is not available/installed?

I was doing everything in the MINGW64 terminal. Thanks for replying.

What directory are you launching your commands from. If you typing them then you should be in your build directory but if you are using the script then you would just be in the darktable directory…ie one level above…not sure this is it but just checking

1 Like

Hi I have made a mess. I tried the development version but it quite often hangs when exporting so wanted to go back to
I saved all original files from appdata/darktable and put them back where they were, but darktable won’t open. Is there anything else I can do or will I have to start again from scratch? I will still have all the edits in sidecar files just will take a while to reconfigure all the settings.

if you installed the dev version overtop of your 3.4 version you will have to re-install it. Is that what you may have done?? This might also be why you have your issue when exporting. I have not had any problems exporting but there can of course be hardware/software issues for each user unique to them. So again how did you install your dev version??
Windows?? Linux?? Mac???

Did you try to run darktable in debug-mode ?

If not, from the Windows cmd-Prompt run:

darktable -d all

DT will write a log-file “C:\Users\USR_NAME_XXXX\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt”

Then inspect the log-file for errors.

Thanks for your help. This was on Windows. I ended up reinstalling and re-importing photos and styles, might not have been the quickest way but it worked…

There are often database updates or new module versions in the dev versions. So there’s no way back. It’s highly recommended to backup stuff …

So you went back to or fixed your dev version??

i was just asking as your problems may have stemmed from the way you installed it. There are a couple of simple steps you can take when installing the dev version and this allows you to run it in parallel with your current version and with no impact on that installation. You just have to establish an alternate config and installation path which is not hard.

Yes I went back to
(had to delete database and import photos again)
I did back up my database files but when I reinstalled the old version, and put the folder containing the original database + all the config files back where it was, darktable wouldn’t open.
I should have paid more attention to how to run a development version and this has taught me that this is worth doing next time! Thanks for your help!

You may be gun shy but it’s pretty easy just a few steps…let me know and I can write it out in detail if you need it

Just had a quick look at the latest DEV version (the one posted above), so what happened to “Basic Adjustments”?
Was grouping multiple functions into one module too user friendly? :sweat_smile:

It hard coded functions into the pipeline in less-than optimal places.

It has been replaced with the “quick access panel” where you can configure as many controls as you like

@priort Much appreciated, I will let you know.
Normally I am willing to have a go at things, but sometimes time is limited. Thanks again.

what about 3D lut module, I cant find this on 3.5.0 version