Darktable v 4.2 Cannot import photos & database issues

Hello and thanks in advance for the help.
Running Linux PoP OS (based on Ubuntu) on System 76
I have been using DT for a while, and recently updated to 4.2
Installed from the PoP OS repository, but also had an installation thru Synaptic Package Manager.
DT will open, with all the images from a previous session showing.
When I click IMPORT, the ADD TO LIBRARY menu will open, to the correct hard drive where my images are stored; but I cannot navigate to the Photos folder I have there. DT locks up with the ‘Darktable is not responding’ message and I have to force quit.
I reopened DT, had to delete database lock files, then reopen again. Still the same problem I cannot import images.
I deleted both DT installations, the one in Synaptic, and the one through PoP OS.
Reinstalled PoP OS only. Still the same problem. I’m thinking I need to delete all configuration files and do a clean install.

Opening Terminal, I navigated to /home/username/.config/darktable
and get the following output. Theres a lot of stuff in there from old installs it looks like, but no lock files at the time. I’m thinking uninstall DT, delete all these files and start over??

user@computer ~> cd /home/anyname/.config/darktable
user@computer ~/.c/darktable> ls
darktablerc library.db-pre-3.0.1
data.db library.db-pre-3.2.1
data.db-pre-3.0.1 library.db-pre-3.4.0
data.db-pre-3.2.1 library.db-pre-3.4.1
data.db-pre-3.4.0 library.db-pre-3.6.0
data.db-pre-3.4.1 library.db-pre-3.6.1
data.db-pre-3.6.0 library.db-pre-3.8.1
data.db-pre-3.6.1 library.db-pre-4.2.0
data.db-pre-3.8.1 library.db-snp-20210721221238
data.db-pre-4.2.0 library.db-snp-20210728225650
data.db-snp-20210721221238 library.db-snp-20210808213702
data.db-snp-20210728225650 library.db-snp-20210821114949
data.db-snp-20210808213702 library.db-snp-20210829130453
data.db-snp-20210821114949 library.db-snp-20210914185229
data.db-snp-20210829130453 library.db-snp-20211029052701
data.db-snp-20210914185229 library.db-snp-20211107082718
data.db-snp-20211029052701 library.db-snp-20211114173019
data.db-snp-20211107082718 library.db-snp-20220424074553
data.db-snp-20211114173019 library.db-snp-20230125163505
data.db-snp-20220424074553 shortcutsrc
data.db-snp-20230125163505 shortcutsrc.backup
keyboardrc shortcutsrc.defaults
keyboardrc_default shortcutsrc.edit
library.db user.css

Any other suggestions?? and thanks!

Additional info:
I installed DT 4.2 with Synaptic, and it works fine. So its a problem with the other version which I think is a Flatpak version. Hope this might clarify things. I have also contacted System 76 to see what they may say about this.

If it is the flatpak you were using, then you’d need to make sure all locations are readable and writable via the flatpak sandbox. You can do that in an app called Flatseal.

However, you’ve been too vague about the sources of your software to really offer any concrete advice.

Sorry about the vague description, I am certain system 76 uses Flatpak for all their software.