Darktable + Wacom: on & off

darktable

#1

Hi,

I have noticed that sometimes my Wacom works just fine, other times doesn’t work at all.
Is there a known bug? Or maybe is not fully supported yet?
Here are my specs:
Win 10x64
Wacom Intuos Pro 651/K

The strange thing is, when I try to use it and is not working, then even the mouse doesn’t work at that point. I can’t even close DT, the only thing I can do is end the task via task manager.


(Hevii Guy) #2

My comment is going to be rather general (yet still helpful, I hope) because I’m now a happy Mac/Linux user after having escaped the not-so-real-after-all shackles of Wyndowze many years ago…

To me this seems as if you’ve got issues external to darktable. To further troubleshoot, have you experienced the same loss of Wacom functionality in other programs (such as Gimp, for example)? Does the mouse always work with non-graphic programs?

BTW: The latest version of darktable on my MacBoxPro gets along well with my PTK-640 (even though I find it of limited benefit when working in dt).


#3

Hi Hevii,

The wacom works with no issues whatsoever in any other software installed on my pc, from Ps to cinema 4d, krita, Coreldraw, etc. I tried capture one and no issues either.


#4

I re-read my first post and I wanted to add that when also the mouse is not working it means I can move the mouse but I can’t click anywhere in the interface. It seems DT doesn’t react to mouse clicks nor the wacom pen clicks. But to be clear, both the mouse and the wagon still work fine in the other programs that are running as well as in Windows.


#5

Is that a USB Wacom?
If so, I would check Window’s device manager for any odd warnings.
Does the Wacom FAQ give any assistance?
You are running Wacom’s latest driver(s)?

Have fun!
Claes in Lund, Sweden


#6

Hi Claes,

Yes, it’s a USB wacom.
No warning of any type in the device manager, all the peripherals are running fine. I’m using the latest drivers.
At this point I think I have to give up on using the wacom with DT. Too bad, especially when it comes to fine-tune the curve


#7

Does this happen with the mouse plugged in only? Sometimes the USB bus power messes up. Could be for a fraction of a second and an app might lose track of the device. Only a guess…


(Mica) #8

I’ve seen the system get confused about which mouse is what and disable both. Perhaps that is still an issue.

Either way, start darktable from the command line in verbose debug mode and post the output.


#9

Hi paperdigits,

Is this the command I’m supposed to use?

darktable.exe [–verbose]

Or should I use darktable-cli.exe?
In which case I’m not sure how to complete the command…


(Hevii Guy) #10

Usually, it’s a Command Line variant of:

darktable -d

It’s OS-dependant. For example, on my MacBox, I must enter:

/Applications/darktable.app/Contents/MacOS/darktable -d

I’m not so sure about your Wyndowze machine :frowning: Nevertheless, give it a shot and enter the above (the first) into your terminal. If it doesn’t work, I’m certain that Mica can lead you in the right direction shortly after the sun comes up over there.


#11

Thank you, Hevii_Guy,

darktable.exe -d didn’t work.


(Mica) #12

You need to use the full path to darktable.exe, something like 'C:\Program Files\darktable\darktable.exe -d'


#13

Hi paperdigits,

I’m executing the command from within the folder.
I tried with the full path, though, just to make sure with the same result.


(Mica) #14

There is no output at all? What about the logs: https://www.darktable.org/about/faq/#faq-windows-logs


#15

This is how the log looks like:

========================================
version: darktable 2.4.4
start: 2018:09:07 09:53:04

> usage: darktable.exe [options] [IMG_1234.{RAW,..}|image_folder/]
> 
> options:
> 
>   --cachedir <user cache directory>
>   --conf <key>=<value>
>   --configdir <user config directory>
>   -d {all,cache,camctl,camsupport,control,dev,fswatch,input,lighttable,
>       lua, masks,memory,nan,opencl,perf,pwstorage,print,sql}
>   --datadir <data directory>
>   --disable-opencl
>   -h, --help, /?
>   --library <library file>
>   --localedir <locale directory>
>   --luacmd <lua command>
>   --moduledir <module directory>
>   --noiseprofiles <noiseprofiles json file>
>   -t <num openmp threads>
>   --tmpdir <tmp directory>
>   --version
> 
>   note: debug log and output will be written to this file:
>         C:\Users\andrayverysame\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt

(Mica) #16

How about the logs?


#17

Not sure to understand… what logs?
The only things in the log folder are these:

[folder] cached_kernels_for_GeForceGTX1080Ti
[folder] mipmaps-16ef8e3ef5c19bd5a4106477a57df487e8647ede.d
darktable-log.txt


(Mica) #18

Those logs, I think.


#19

that’s the one I posted above:


(Mica) #20

That’s the debug log?