darktable windows insider program 8/14

Work meetings, so i cant test at the moment.

Can you also do a -d perf to confirm it is the CPU path? When you select Very fast GPU, it tries to only use the GPU path and not the CPU.

Thanks for starting the Issue in GitHub. We should continue the conversation there instead of here.

I was able to reproduce turning OpenCL off. I wonder when this started since I always have OpenCL on and I’m using fedora more than windows lately.

There is a possibility that I didn’t build correctly, since I was using new instructions. I ran the build I created on the machine it was created on without problems. I ran it on a win 10 machine and it crashed every time I tried any kind of edit. I pulled the latest from today and rebuilt using my build scripts, then tested on win10 and everything seems to work fine.

Here’s the link to the new build, https://drive.google.com/file/d/1OZnPac0_NxgsINH8xkBD4_zZ85jWv6x1/view?usp=sharing. Try it and see if the problems go away.

Your new one crashes without any message, also no event in the win-protocol.

OpenCL GPU only seems still solid.

Just tried again on windows 10 and now it’s crashing with Magick: caught exception 0XC0000005 Access violation. I caught it by running darktable in a windows command prompt.

@wpferguson I posted this in GitHub

I remember that I still have a few of the .exe files from my previous builds. Ive installed them in a clean directory to see when I can get it to reproduce. So far I’ve tested 4.1.0+19, +67, +109 and no issues. At +175, it did crash. I’ve been using UCRT since +67.

I always get the Magick: …

the last commit I have that does not crash (+109) : 4ea7e5d5cc0d5e98a322a64eea62e0c7d38e6e43
the first commit I have that does crash (+175): 808361fe8bdce378dc65d2f813b0f883b090cb95

I’m at work but just recently switched to UCRT. I will try a build when I get home if you like…

Last weeks insider build 123 is fine too.

Can you get me the commit?

Sorry, me n00b. Filename says 4.1.0+123~g51460ce3e. Is this what you need?

Last part of the file name will target where you were when you built it…

In GitHub, the commits are like a ledger in a bankbook (before we had electronic stuff). It allows us to go back in “time” and get the code at that point in “time”. This allows me to build darktable how it was that day to try to find what change introduced the issue. You saved me some work.

So far, 4.1.0+130~gec1d273b8 is still good.

1 Like

One commit after that one is when the problem starts for me.