Darktable won't read images in new film rolls

Forgive me if this is a known fix I just missed in the database.

Darktable / Lightroom won’t open the images in the newest few directories of files on my hard drive, and this is not an obvious issue of filter by date. I don’t know if this is a thing like having too many (several thousand) images previously opened, or a bug, or me being an idiot.

If I say “Import Folder” for the last two or three directories of NEF+JPG, nothing happens (“There are not images in this collection”). If I go to older folders, the images import fine. (I have a screen shot but don’t see an obvious “inset image” here, sorry.)

Anyway, any thoughts? I would be happy to add more details if needed.

Do you need to recursively import images? Check the box on the import screen.

To upload a screenshot, just drag and drop.it on the editor window.

Try right clicking on particular folder, then choose “Open with…” and your desired program (DT or LR). It will appear as new film roll and will be opened in lighttable. I don’t import, but always load folder to DT this method. I sort/copy using external software, then load to DT or RT.

How much free space do you have on this partition?

Thanks for the help. Let me drag and drop the image…

Windows 10, I should have said.

I’ve tried with an without recursive. I don’t have “Open with… Darktable” on right click, and “Send to… Darktable” gave a “strange path found” error.

To reiterate, folders created before a certain date open fine, but new ones fail. I wonder if there’s a limit to how many umpteen thousand raw+jpg in the history? Can I clear the history?

I did a repair re-install of 3.2.1 and no change.

I assume I’m doing something stupid but I don’t know what.

Any thoughts?


sqlite starts to slow down at hundreds of thousands of objects, but it just slows down, it still works. So I don’t think that is your problem.

I don’t see anything obviously wrong with your screenshot…

Are you seeing any error dialogs?

In the screenshot the two most recent collections (and the active one) have a name ending with a ‘%’ character. Is that indeed the correct name? OR did you change an import script, which now has an extraneous ‘%’?

1 Like

Thanks for the comments. The % being present or absent makes no difference.

Ultimately, any folder moved to the computer after a certain time won’t read in.

IS there a “factory reset” command? I uninstalled and re-installed which left all of my recently viewed directories, etc., in place so I clearly didn’t get the config files.


Delete the darktable config folder.

Is there spaces or some weird characters in the folder name/path?

There were no odd characters in any of the failed directories.

I ended up uninstalling and nuking c/users/username/AppData/Local/Darktable and then reinstalling — that appears to have fixed it.

How odd.

Did you back up your styles etc? If not, you will have to re-create all. They can be backed up to safe, non-database text files, then “imported” to newly installed DT.