digiKam Database Migration Conundrum


#1

As I must have exceeded my amount of consecutive postings in my Tags View thread, and this can stand alone as a separate topic anyway, here goes:

In my ongoing crusade to find a cure for my Tags View problem, although everything says the drive that contains my database is healthy, as I have tried just about every other thing that I could think of, I decided to give migrating the database to a different a try.

I made me a folder for the database to reside, went to the database migration dialogue, browsed to my new folder, and ran the migration process.

After a bit, a digiKam4 database file appeared; then, a second file showed up – journal something or other.

After a few hours, a pop-up told me that the task had completed successfully.
At this point, the journal file had disappeared and there was only the digiKam4 file; there were no thumbnails or recognition files; I thought …well, I guess it needs to restart.

I restarted digiKam and it was as if I hadn’t done a thing in all of those hours; both path addresses in the migration dialogue had the path to my original folder.

I went nosing around and in Configure digiKam I found a database settings dialogue; I browsed to my new folder and clicked Okay.
A notice popped up that said I did not have write access; I most certainly did have write access.

I investigated and sure enough I had full control; I gave “Everyone” full control just for good measure.

Tried again and got the same message = no write access.
I investigated again and I cannot see any way anywhere that I could provide more permissions than are already there.

I restarted the machine = still no go.

Am I missing a trick or what am I doing wrong ?
I have read and reread the manual and no help there that I could see.


(Hevii Guy) #2

No solutions (sorry), just comments:

You wouldn’t happen to be storing your files on an NTFS-formatted external HDD, huh? If so, you’ll have to do some funky things with fstab to enable your permissions to stick.

Make sure that your database user as defined in digikam is the same entity who created the database.


#3

Thanks for the moral support.
All digiKam associated business is on internal NTFS HDDs (Windows 7)
So far as I remember, the initial installation was done under my current username; but then, way back when, I did have to create a bunch of separate usernames in order to finally get a handle on seamless file/folder sharing between all the machines on our home network; it is not impossible that I may have got something switched, but I don’t think so.
The annoying thing is, I can access that silly folder with full control from all of our other machines, not to mention the one in question, but digiKam insists that it cannot.


#4

You might want to consider resetting the permissions to their default. See: https://ss64.com/nt/icacls.html.


#5

I’ve been using digikam 6.0 betas all of autumn - and today I downloaded latest beta 3 build - but now for the first time when launching the app digikam hangs- App windows opens and I see my tags and pics but the app goes “not responding” right away when clicking it. restarting it many times not helping - just hangs.

So I downloaded official beta 2 and I see my content in the app but it just keeps hanging no matter what.

Using latest MariaDB 10.3

What is there left to try? Just two days ago I DL’d and installed previous beta 3 build and digikam worked fine. But this most latest beta 3 build is not responding and now I fear losing DB…

What to try to solve?

Windows 10 x64

Edit: when it starts to hang mysql.exe is killed and it’s not relaunching until the app is relaunched… but then it “dies” again and digikam hangs :confused: