Dismiss the invitation to receive live notifications


(Elle Stone) #1

On my screen, at the top of the pixls.us forum is the question "Do you want live notifications when people reply to your posts?

There is a link to click to “Enable Notifications” and off to one side is an “X” which looks like it ought to function to make the offer to get live notifications disappear.

Clicking on the “X” doesn’t do anything - the question about live notifications remains visible.

I really don’t want the live notifications - by which I mean the little popups that provide an excerpt from the thread. Is there a way to make the question about enabling notifications disappear without actually enabling the notifications?

Maybe my browser has too much security software enabled so the “X” doesn’t work? I thought the only thing I blocked for pixls.us was google analytics, but perhaps there’s something else that’s still functioning.


#2

Hi Elle,

Odd. When I click the X, the offer disappears.

FYI: I am on Firefox 63.0.1 and have Ghostery as
well as AdBlock Plus on.

Have fun!
Claes in Lund, Sweden


(Elle Stone) #3

Hmm, I’m using Firefox 52.8 and instead of getting live notifications (because I didn’t click to enable them), I’m getting popups asking me if I want live notifications, which I forgot to mention but that’s just as bad as getting the live notifications.

I have Adblock Plus, NoScript, a couple of miner blockers (I don’t block pixls.us), HTTPS everywhere, Privacy Badger, and Self-Destructing cookies. This latter doesn’t operate until the site is closed. The only type of cookie I block through the browser settings is third-party cookies.

I guess I can try disabling each add-on in turn to see which one might be blocking my effort to click the X and stop the popup invitations to see the live notifications.

Edit: Checking Firefox Preferences, it’s set to block pop-ups, so I guess it’s not doing a very good job!


(Elle Stone) #4

OK, I disabled every single Firefox add-on, security-related and otherwise, and I also disabled through the browser the blocking of pop-ups, and restarted Firefox. Clicking on the “X” still doesn’t dismiss the invitation to receive live notifications.

But clicking on “Enable Notifications” does work (and has always worked). This seems very odd.

Does the “X” to dismiss the invitation to receive live notifications depend on some technology that’s different than the technology to accept the invitation?

There are no plug-ins enabled in my version of Firefox, but I doubt pixls.us depends on flash or any such thing, so that shouldn’t matter.

I’m using the pixls.us dark theme - would the theme make a difference?


#5

Hm… According to Ghostery, pixls.us uses two trackers: Google Analytics and Piwik. I just blocked those two as well – but the X click you mention still works here. I think we’d better ping @patdavid

Have fun!
Claes in Lund, Sweden


(Mica) #6

The notifications have nothing to do with Google analytics or piwik, but rather is a feature of the browser. My Firefox, version 63, has a “don’t show” button in that pop up.


#7

Thank you @paperdigits! (unping @patdavid)

@Elle Check your Firefox-settings
Open menu (i.e. the hamburger icon) -> Preferences -> Privacy & Security -> Permissions -> Notifications -> Settings -> Tick Block new requests…

Can’t vouch for your ff version, but in mine, there it is!

Have fun!
Claes in Lund, Sweden


(Mica) #8

This has nothing to do with the question at hand, but Firefox versions >58 are really good. New rendering engine. Totally worth the upgrade.


(Elle Stone) #9

Oh, wow! thanks! that works! On my version of Firefox there is no such option in Preferences as @Claes mentions, but there is stuff in about:config when searching for “notifications”. So I disabled notifications and presto - that awful repetitive pestering to enable live notifications is gone!

All this time I thought it was something on pixls and it actually was the browser - @paperdigits and @Claes - thank you thank you thank you!


(Mica) #10

It is something between the website and the browser. Lots of sites have them and its usually fairly annoying.


#11

As an aside, why Adblock Plus and not Ublock Origin? It’s my understanding that ubo is much better.


#12

@Kirtai
Why? Simply because of old habits, I guess :slight_smile:

Have fun!
Claes in Lund, Sweden


#13

Disable (set to false):

  • dom.webnotifications.enabled
  • dom.push.enabled

(darix) #14

@Elle and your firefox 52.x still has security updates?


(Elle Stone) #15

You know how sometimes you just dig your feet in and say “no”?

I’ve been using Firefox since before it was Firefox, back when it was still Firebird. I’ve rolled along with each update and been pretty happy. Each step of the way I upgraded the addons and gone into “about:config” and made newly-required privacy and security settings.

Then came the update when the status bar was removed and the ability to have the same “find” box at the bottom of each tab was removed. I don’t like that at all, it makes searching for information across multiple tabs rather more difficult.

Then came a lot of new functionality that I don’t use, that carries what I consider to be additional privacy and security problems - geolocation, increased integration with google, offers to integrate with some cloud service, a bunch of stuff. And every time I let Firefox be upgraded my old about:config settings just seem to get overwritten to new defaults that I don’t want. So I would search the internet for new security and privacy concerns regarding the new Firefox, and new changes to make in about:config. But my sense that “yes, this stuff is all working” grew less and less.

Then came quantum. I don’t like quantum. I just don’t like it. So I’ve dug my feet in. I have pale moon installed. I also have a third version of Firefox installed that’s older than the version I use for the pixls website.

I don’t think Firefox serves my particular browsing goals very well any more and I’m tired of perusing the internet looking for how to deal with the latest and greatest Firefox. So I decided not to.

The only reason I use Firefox at all is because it’s color-managed, though not as well as it was before the Firefox people decided to roll their own color management.