DT 4.8 Color Picker mismatch L value with peaking indicator and histogram

hi,

I hope you can see from attached, with Color Picker set to Lab and Peak, it shows peak L to be well under 100, despite the peaking indicator and histogram both showing lots of clipping.

It seems that the L values are not reporting correctly.

This DT 4.8 issue was not present in prior versions.

thank you

Please read: darktable 4.6 user manual - clipping warning

There could be a number of reasons for the clipping warning to show (luminance, RGB channel, saturation, all of those combined).

Load this into darktable – clearly, nothing is overly bright, but the primaries are fully saturated, and thus warrant a gamut warning.

What is your histogram profile… that will be what the histogram is drawn from…may not jive with LAB… And gamut warnings use the softproofing profile for the gamut tool indicator but they use the histogram profile if you check with the overexposure tool set to full gamut… and you display profile can also come into play… it can have the ability to impact picker values… if setting your display profile to linear rec2020 changes values from what is shown when you use your normal display profile then it is introducing some clipping and affecting the values…

What is your clipping indicator set for…

This should align better… ie luminance only

image

EDIT Your picker I noticed is a region correct?? What if you change it to a point selection and select in the gamut warning area… 100 % then??

This image…

Crank the exposure

Gamut on Luma rec2020

Gamut on Luma srgb

Selecting anything in purple will give me L value of 100…

image

If I was to switch to full gamut almost all the image would be out in srgb but many areas would not have L values… you may infact have luminance set as your mode but I think you used a region not a point measure in your example…

Thanks guys @kofa and @priort.

But note that this was not happening before v4.8. And I didn’t change anything eg gamut.

Todd I admit some of your comments are not at my (low) level.

Here are my clipping indicator settings:-
Screenshot 2024-07-15 at 9.26.54 PM

Histogram profile:-

And here are my general settings:-

It always worked perfectly: if I set the color picker to ‘max’ and ‘Lab’, and ‘picked’ an area with ‘restrict scope to selection’ turned on, then the picker’s L value would reach 100 just as the peaking indicator started to indicate peaking, and just as the scope (rgb parade) started to max on one of the channels. No longer.

thanks

Yes, set to any RGB channel. So, a deeply saturated, but relatively dark blue (see the image in DT 4.8 Color Picker mismatch L value with peaking indicator and histogram - #2 by kofa) will trigger it. If you want L (lightness)-based clipping indication, set it accordingly (luminance only).

2 Likes

Setting your softproofing to linear prophoto is not going to give you anything…no output device has that gamut and your monitor unless it is very high end will not show any impact on the image if you set it for soft proofing. It will change the histogram when you engage softproofing and it will use linear prophoto for the gamut indicator using the dedicated gamut warning icon.

Checking gamut with the over-exposure icon has options on what it will monitor and it uses the histogram profile as a reference… so it will use that profile whatever you use for your histogram to determine gamut…

1 Like