DT import from Lightroom

I tried an DT import with some .CR2 files which i processed in LR. The corresponding xmp files are available.
After import in DT it seems the changes are not visible at the lighttable (for instance crop). But if I double click an image (jump to darkroom) I see the changes. Back to lighttable, same results no changes visible.
I assume that’s not a normal behavior. Could it be I’m doing something wrong? Or are there some preferences I have to set?
I know, there is no 1:1 takeover from LR possible, I read already some articles an threads.
Thank you very much for any hint and help.
Regards Andreas

After running the import, quit darktable and run the darktable-generate-cache command from the terminal.

No, not normal. I suppose that if in darkroom you change some params the thumbs on the lighttable is changed? If so, probably a caching issue not properly detecting that the thumbs is to be recomputed.

Thanks @paperdigits and @Pascal_Obry for your answers.
Yes it seems to be a caching problem. You are right, if I do a change in darkroom It’s then visible also in lighttable.
I run the darktable-generate-cache with admin rights. It dosn’t solve the problem, but I forgot to tell you: I’m using Windows10.
There are some Warnings, no idea how to deal with it.

(darktable-generate-cache:6064): Gtk-WARNING **: 08:58:16.346: gtk_disable_setlocale() must be called before gtk_init()

(darktable-generate-cache:6064): GLib-GIO-WARNING **: 08:58:17.080: Unexpectedly, UWP app `Microsoft.Print3D_3.3.791.0_x64__8wekyb3d8bbwe' (AUMId `Microsoft.Print3D_8wekyb3d8bbwe!App') supports 5 extensions but has no verbs
erzeuge vollständigen Leuchttisch-Vorschau-Cache
erstelle Cache-Verzeichnisse
erstelle Cache-Verzeichnis ÔÇ×C:\Users\admin\AppData\Local\Microsoft\Windows\INetCache\darktable/mipmaps-b1f8f5b7f9952f6d8c852863c8f96f1fe7db0926.d/0ÔÇØ
erstelle Cache-Verzeichnis ÔÇ×C:\Users\admin\AppData\Local\Microsoft\Windows\INetCache\darktable/mipmaps-b1f8f5b7f9952f6d8c852863c8f96f1fe7db0926.d/1ÔÇØ
erstelle Cache-Verzeichnis ÔÇ×C:\Users\admin\AppData\Local\Microsoft\Windows\INetCache\darktable/mipmaps-b1f8f5b7f9952f6d8c852863c8f96f1fe7db0926.d/2ÔÇØ
Warnung: Im angeforderten Bereich wurden keine Bild-IDs gefunden