Exported JPEGs with sRGB output profile looks desaturated

Hi!

When I export images to jpeg, they look desaturated. Original sample:

Exported sample:

I have already set the Output Profile to sRGB (after setting the Preferences -> Color management -> directory to /usr/share/color/icc/colord/, where I can find the profiles).

I don’t know if that’s related, but if I open the image properties with the file explorer, ColorSpace appears as uncalibrated.

I’m using RawTherapee 5.8 on ArchLinux.

Thanks! :heart:

Welcome @juanignaciosl

I assume that original sample means jpg Out Of the Camera. In this case, the SW of the camera can apply a lot of different processing to obtain something pleasing to the photographer. If the jpg is good, there is no need to process the raw.

If not satisfying then raw processing comes.
The raw processor only apply those functions and parameters you have selected and thus the result can (and should) be different from the OOC jpg . To obtain the desired result you will have to activate functions and set their parameters.
for instance, if export looks unsaturated, increase saturation as needed.

rawpedia is your friend. You can have a look at http://rawpedia.rawtherapee.com/Editor#Eek.21_My_Raw_Photo_Looks_Different_than_the_Camera_JPEG

My above hypothesis can be wrong, then additional investigation will be needed

It looks a bit strange. If you have very saturated colors in the photo it is normal that they look less saturated when you export them to srgb/jpg. Very saturated colors do not fit into the srgb color space and cannot be displayed on normal screens.

Under normal circumstances the difference should not be so siginficant though.

But it is also possible that you chose a very strong compression for the exported jpg. Jpg compression sometimes also desaturates the colors.

It is also possible that it is a combination of the two factors.

What kind of screen do you have and how have you calibrated it?

2 Likes

First of all, thank you for your support :). Let me answer you questions:

I assume that original sample means jpg Out Of the Camera.

Nope, sorry, I should’ve been explicit about that. That’s a screenshot from the working image on RawTherapee. Screenshooting generates a PNG, which doesn’t have the desaturation problem. Then, the file was converted to JPEG.

rawpedia is your friend

Yep, I’ve read the Eek! page, and two related to Color Management (https://rawpedia.rawtherapee.com/Color_Management and https://rawpedia.rawtherapee.com/Color_Management_addon). There I realized that I hadn’t chosen the output profile (coming from Lightroom, I had expected it to be an export step). Anyway, selecting sRGB didn’t make a difference.

Very saturated colors do not fit into the srgb color space and cannot be displayed on normal screens.

Yep, but that’s not my case. The first image is a PNG screenshot of what I’m seeing at RT, which is later converted to JPEG and still looks fine (maybe some subtle nuances, but you need a trained eye for realizing). That proofs that the colors of my image fit into the sRGB space.

It is also possible that it is a combination of the two factors.

Nop, I tried with maximum quality, no difference.

What kind of screen do you have and how have you calibrated it?

A Dell U2713H (IPS panel) that I calibrated with a Spyder calibrator years ago. But my laptop (XPS 7590, uncalibrated IPS screen) shows the same colors. Anyway, because of the PNG -> JPEG conversion results, I wouldn’t say that it’s the problem.

This is embarrassing… today it’s working :disappointed_relieved:

I don’t know what I have done differently, other than restarting RT (again, I had already done it after copying the profiles to a different folder). Now, as you could expect, you get some minor differences, but nothing remarkable.

For future reference, did sudo cp /usr/share/color/icc/colord/* /usr/share/rawtherapee/iccprofiles/output (because I saw it at https://rawpedia.rawtherapee.com/Color_Management_addon, but I’m not sure if it’s still needed, since it’s a configuration parameter). And setting sRGB as output profile. Perceptual rendering intent with black point compensation is also selected.

Again, thank you very much. I’m sorry about the loss of time, I can’t explain what happened :frowning:

Ok. Even yesterday’s exports look ok. I think that the problem is at my computer color profile management.

Yesterday I was working with my laptop and external monitor through HDMI. No matter what I did, colors became desaturated at both monitors (I detected it after uploading to Flickr, but the local files also looked desaturated). After some hours of trial and error, I suspended the computer and left.

Today I unplugged the HDMI and begun working just with the laptop, and everything looks fine. So, I think that GNOME? Xorg? wasn’t handling the sRGB color profile properly. Not related to RT at all 🤷 I’m going to take a look at https://wiki.archlinux.org/index.php/ICC_profiles

I could’ve detected it by opening the files with another system (such as the cellphone), but I didn’t realize.

yeah, colormgmt and linux :slight_smile:

did a fresh install of fedora/xfce last month, and had to google all the colord stuff for one day.
Finally, i realized that community driven xiccd was outdated, eats up heating cpu.
Had to compile xiccd by myself, but that’s not the fresh-beginner-linux-onboarding-style :wink: