Face tags missing after move from Picasa

Hello. I’ve recently moved to DigiKam from Google Picasa. So far I’m really liking it. Prior to the move I went through all my photos in Picasa and got the face tags up to date. I set Picasa to store the face tags in the photo files rather than anywhere else. Now I’m viewing the photos in Digikam and some of the face tags show up in Digikam, but some don’t. I’ve looked at the exif data for a couple of files where the face tags aren’t showing up and they are definitely there in the files (in the XMP section if that’s relevant,but please note that this is where the face tags are in the files that DID work too). It would be great not to have to go through all my thousands of photos again tagging the faces. Can I get digikam to “notice” the face tags already in the files? Many thanks


I think your face tags are there but they just located in a wrong part of the pictures. Please try hovering the mouse over a sample picture and you might find the face region.

I had this problem with some images awhile ago. I think only the portrait oriented JPGs were affected.

Thank you but I don’t think that’s it. When I click on people on the left hand side, the list is extremely short. Most of the people I tagged in Picasa aren’t even mentioned in the list. Thanks again.

It s hard to guess anything without a sample picture…

OK, do you mean a screenshot or attaching one of the photos in question?

No not a screenshot. We would need one of the images you are having issues with.

OK, thanks. I’ve attached an image. This photo includes a tag for the one person in it. It shows up in Picasa and in an exif viewer. That tag isn’t showing in Digikam, and the person’s name doesn’t appear in the list when I click “People” at the far left of the Digikam interface. Thanks for any help you can offer.

Please look at my screenshot.
The face region for Jim Munford is there but it is in a wrong place.
This is exactly the issue I had. How to fix that? I don’t know.
I bet it has something to do with the portrait orientation.
If you have thousands of these I would invest time in writing a script.
I think exiftool should be able to fix that, you just need to figure out the exact command.

Thank you but that’s not what I’m seeing in Digikam. For me, there is no face tag at all on that photo and Jim Munford does not appear in the list of people who are tagged in my photos. Also, when I hover over the thumbnail, no faces are listed in the summary box (see attachment).


It does show the tag in my digiKam 6.3.0. …
It also showed up in People Tab in the Left Panel.

That’s interesting. I’m also running 6.3.0. Any thoughts as to why mine is behaving so oddly?

Not sure. Can you try downloading your own file from your post and importing it as a new file (the file name will be more like what you see on my screenshot instead of IMG XXXX) ?

I’ll give it a try. Meanwhile, could you clarify import? What I have done is to have my pictures stored on a drive and then added their directory in the Collections tab of the Configure Digikam option on the Settings menu. Is that what you mean by Import or should I have done something different? Thank you for your help on all this!

I just saved your photo to the root of my collection (e.g. /home/user/Pictures or C:\Users\user\Pictures and then opened the folder in digikam and pressed F5.

You can also click on the image in digiKam then go to the Item menu and click on “Reread Metadata from file”

OK. I’ve just done “reread metadata from file” on the image and Jim Munford is now tagged in that image. He also appears in my list of people. The tag is slightly in the wrong place, but I’ll ignore that for now! That’s a step forwards. How do I get it to reread the metadata for the entire collection (rather than one photo at a time)?

Or maybe there’s a better way to add my Photos to Digikam so that the metadata is read first time?

I would go to Tools - Maintenance -

Select your whole collection in the top part (Tab “Album”),

(Be careful with the “work on all processor cores” option. I have had a very little luck with it in the past. It was an easy way to crash the application for sure.)

then check the box “Sync Metadata and Database” , sync direction - “from image metadata to database”

Let it run, it might take a while.

If it crashes you can do so Album by Album. There is also “Reread metadata” option in the Album top menu.

Thank you. I’ll have a go tomorrow…

I’ve had a go and it seems to have worked (although as we discussed previously, some of the tags are not on the faces!). Thank you!

As it stands, I’ve only added my 2019 photos to Digikam, mainly to get used to Digikam and see if I like it as a replacement for Picasa (which I do!).

When I add the rest of my photos, is there a way to do it so that the Sync Metadata and Database step isn’t required? Don’t worry if there isn’t - I’ll just set it going and go out for the evening!

Thanks again.