Folder selection problem in lighttable

I’ve run into a problem with the lighttable collect images module. The list of folders displayed on the screen can show spurious folder names if other folder names are similar.

I’m running darktable 2.7.0~git1930.268ac553e

Let me explain:
I typically collect my raw files into Year/Activity (or location) folder names. So ‘2019/Car Museum’ for example. I’m presently visiting in Cyprus and so have added an additional nesting level: ‘2019/Cyprus/Beach at night’ for example. I visited Cyprus earlier in the year and the photos I collected went into a ‘2019/Cyprus Trip/…’ folder. Now as I import new files (into ‘2019/Cyprus/…’ the ‘Cyprus’ folder showed up twice on the screen. It would look like:

Cyprus
Cyprus Trip
Cyprus

and some of my directories would show up in the first one and the rest in the second ‘Cyprus’ folder.

I tried purging and re-importing all of my photos, but that didn’t help.
What did fix the problem was to rename ‘Cyprus Trip’ to something like ‘First Cyprus Trip’. Once I did that, it only displayed on ‘Cyprus’ folder and all of my images were there. I think there might be a problem with a database query that fetches the folder names. Perhaps it’s using a wildcard search or something.

I’m really enjoying all of the improvements to darktable so far, despite the little niggles.

Hi @Inchoate,
Two odd thoughts: might you have been using
tagging as well? Since you are using a git version,
might there be a database collision from going from
one release to another?

Have fun!
Claes in Lund, Sweden

Are you referring to git tagging? No, I am just using a PPA I found for newer releases.

I think I have seen symptoms of this previously (I have been using darktable for several years).

No, I thought of the tagging module in lighttable’s right column.


It was just a hunch, though…

Oh, I’ve used that in the past, but I haven’t tagged any of the photos in the problem directories yet.

Just a thought (depending on your OS): have you tried using dashes or underscores in the directory names instead of blanks, i.e., ‘2019/Car-Museum’, ‘2019/Cyprus-Trip’, and so on?

I have not yet (it doesn’t really fit in to my naming patters), but I’m sure that it would solve the problem as well. I’ve had problems several times over the past few years with directory name matching problems. In each case it was because a directory name like ‘foo bar’ collided with a directory named ‘foo bar baz’. That’s a similar problem here, where one directory is ‘Cyprus Visit’ and another is just ‘Cyprus’. Those are pretty distinctly different directory names, yet darktable is using some type of wild-card matching or something and gets confused.

Thanks for the responses!

I am still thinking about your problem…
(And, so far, I have not become a bit wiser :frowning: )

In darktable/preferences in the GUI options tab: do you have the recursive directory traversal when importing filmrolls ticked or not?

Yes, I do.
Since I use spaces in my directory names, I suspect that it somehow gets a match between names that have similar leading words (‘foo bar’ and ‘foo’)