Gimp 2.10 plugins


(Lyle Kroll) #22

You still need to download and install PSPI; it’s not part of GIMP itself. Tor originated it and still hosts it. :slight_smile:

http://the-tml.net/gimp/pspi.html


#23

Thanks; that is good to know.
I have had the NIK Collection since way back when it was free and use it almost daily; I had forgotten that it could run as stand-alone.
Thanks for the PSPI link as well.


(Lyle Kroll) #24

I posted at the link below how to get the NIK collection to run via Shellout, BuckSkin. Some of the presets don’t transfer to GIMP though; you have to save result to a location and close (bummer) but still GIMP will at least pass the file to the NIK preset. :slight_smile:

https://www.dpreview.com/forums/post/57503130


#25

Thanks !


(Bob Cat) #26

I am running OS X. I’ve downloaded 2.10.8 and McGimp and have been throwing old 2.8 synthesize.py files into the new plugin directory. And all kinds of weird hail-mary’s

I started clean twice. I can’t get the Filter> Enhance>Heal working.
I set parameters click ok and get:

Calling Error for procedure ‘gimp-porocedural-db-proc-info’:
Procedure ‘plug-in-resynthesizer’ not found.

Can anyone suggest a download site and install instructions. So I can use this or shed some light on this.

Thanks.


#27

The resynthesizer is actually a couple of Python plug-ins and a binary (called resynthesizer in its Linux form). So you need a binary that runs with Gimp 2.10 (so possibly recompiled for it) on your platform.


(Carmelo Dr Raw) #28

For your information, I am setting up a repository for pre-compiled GIMP plugins for MacOS. This is the link: https://github.com/aferrero2707/gimp-plugins-collection?files=1

I will try to add the resynthesizer soon after the Christmas break.


(Carmelo Dr Raw) #29

I have a skeleton Resynthetizer plug-in under development, but is it still not functional.
Once ready, the binary package for MacOS will be available here: https://github.com/aferrero2707/gimp-plugins-collection/releases/tag/continuous


(Bob Cat) #30

Thanks Carmelo. That sounds like what I’m looking for. When downloaded, do I just drop it in the plugins directory and start Gimp. Or is their some terminal command lines I need to type?


(Carmelo Dr Raw) #31

I have put the instructions in the release page.

Notice that for selection healing/inpainting you can also use the already available GMIC plugin.

There is also liquid rescale if you are interested in content-aware resizing…


(Carmelo Dr Raw) #32

The Resynthetizer plugin for MacOS is ready for download. Please visit https://github.com/aferrero2707/gimp-plugins-collection/releases/tag/continuous and follow the instructions at the bottom of the packages list.

Could you let me know if it works properly in your case?


(Bob Cat) #33

I seem to be having trouble with everything.

-The GMIC healing inpainting leaves the mask untouched, but no errors.

-After installing your resynth and liquid. And confirming the terminal commands were executed properly and the files when to the correct folder, I now have 2 entries called Filters/Enhance/Heal Selection.

–The first is python_fu_heal_selection it calls a Python with version 2.7 (Not Python3)

It throws an error procedure not found as before
Calling Error for procedure ‘gimp-porocedural-db-proc-info’:
Procedure ‘plug-in-resynthesizer’ not found.

Traceback (most recent call last):
File “/Applications/McGimp-2.10.8.app/Contents/Resources/lib/gimp/2.0/python/gimpfu.py”, line 740, in response
dialog.res = run_script(params)
File “/Applications/McGimp-2.10.8.app/Contents/Resources/lib/gimp/2.0/python/gimpfu.py”, line 361, in run_script
return apply(function, params)
File “/Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/plugin-heal-selection.py”, line 148, in heal_selection
pdb.plug_in_resynthesizer(timg, tdrawable, 0,0, useBorder, work_drawable.ID, -1, -1, 0.0, 0.117, 16, 500)
error: procedure not found

–The second is Script_Fu: Heal Selection

It gives off this message:
Error while executing script-fu-smart-remove:

Error: eval: unbound variable: plug-in-resynthesizer

I searched but couldn’t find a filter named Liquid Rescale or similar. So I’m not sure if Gimp is even loading these new plugins.

That’s about where I am. Any suggestions?


(Carmelo Dr Raw) #34

@Bob_The_Water_Cat to dig further into your problem, I would need the full terminal output of GIMP.

Could you please run this command:

/Applications/GIMP-2.10.app/Contents/MacOS/gimp >& gimp-log.txt

and post the log file? You might need to replace /Applications/GIMP-2.10.app with the actual path to the GIMP bundle on your system.

It would also be useful to have the output of

ls -lhrt "$HOME/Library/Application Support/GIMP/2.10/plug-ins"

Thanks!


(Bob Cat) #35

For this command line
Mac-mini:plug-ins XXX$ /Applications/McGimp-2.10.8.app/Contents/MacOS/gimp >& gimp-log.txt

When executed opens Gimp and then seems to hang. It is generating a huge file. I hit ctrlC. The below gimp-log.txt in the plugins Dir is over 500 pages before I killed it. Here is a sample:

This reoccurs frequently
This likely means that your installation is broken.

Try running the command

gdk-pixbuf-query-loaders > /Applications/McGimp-2.10.8.app/Contents/MacOS/…/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

to make things work again for the time being.

(gimp:23515): GLib-GIO-CRITICAL **: 07:37:39.632: g_loadable_icon_load: assertion ‘G_IS_LOADABLE_ICON (icon)’ failed

(gimp:23515): Gtk-WARNING **: 07:37:39.632: Error loading theme icon ‘image-missing’ for stock: Failed to load icon

(gimp:23515): Gtk-CRITICAL **: 07:37:39.632: render_fallback_image: assertion ‘pixbuf != NULL’ failed

(gimp:23515): GLib-GObject-CRITICAL **: 07:37:39.632: g_object_ref: assertion ‘G_IS_OBJECT (object)’ failed

(gimp:23515): GLib-GObject-CRITICAL **: 07:37:39.632: g_object_unref: assertion ‘G_IS_OBJECT (object)’ failed

(gimp:23515): GdkPixbuf-WARNING **: 07:37:39.633: Cannot open pixbuf loader module file ‘/Applications/McGimp-2.10.8.app/Contents/MacOS/…/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache’: No such file or directory

This likely means that your installation is broken.

Try running the command

gdk-pixbuf-query-loaders > /Applications/McGimp-2.10.8.app/Contents/MacOS/…/lib/gdk-pixbuf-2.0/2.10.0/loaders.cache

to make things work again for the time being.

Plus this bit is common. Most of the 500 plus pages is made up of these

dyld: Library not loaded: @rpath/libgimpui-2.0.0.dylib
Referenced from: /Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/resynthesizer_gui
Reason: no suitable image found. Did find:
/usr/local/lib/libgimpui-2.0.0.dylib: stat() failed with errno=13
/Applications/McGimp-2.10.8.app/Contents/MacOS/gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
dyld: Library not loaded: @rpath/libgimpui-2.0.0.dylib
Referenced from: /Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/resynthesizer
Reason: no suitable image found. Did find:
/usr/local/lib/libgimpui-2.0.0.dylib: stat() failed with errno=13
/Applications/McGimp-2.10.8.app/Contents/MacOS/gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
dyld: Library not loaded: /Users/travis/build/aferrero2707/gimp-plugins-collection/inst/lib/libgimpui-2.0.0.dylib
Referenced from: /Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/plug_in_lqr_iter-orig
Reason: no suitable image found. Did find:
/usr/local/lib/libgimpui-2.0.0.dylib: stat() failed with errno=13
/Applications/McGimp-2.10.8.app/Contents/MacOS/gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
dyld: Library not loaded: @rpath/libgimpui-2.0.0.dylib
Referenced from: /Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/plug_in_lqr_iter
Reason: no suitable image found. Did find:
/usr/local/lib/libgimpui-2.0.0.dylib: stat() failed with errno=13
/Applications/McGimp-2.10.8.app/Contents/MacOS/gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
dyld: Library not loaded: /Users/travis/build/aferrero2707/gimp-plugins-collection/inst/lib/libgimpui-2.0.0.dylib
Referenced from: /Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/gimp-lqr-plugin-orig
Reason: no suitable image found. Did find:
/usr/local/lib/libgimpui-2.0.0.dylib: stat() failed with errno=13
/Applications/McGimp-2.10.8.app/Contents/MacOS/gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error
dyld: Library not loaded: @rpath/libgimpui-2.0.0.dylib
Referenced from: /Users/XXX/Library/Application Support/GIMP/2.10/plug-ins/gimp-lqr-plugin
Reason: no suitable image found. Did find:
/usr/local/lib/libgimpui-2.0.0.dylib: stat() failed with errno=13
/Applications/McGimp-2.10.8.app/Contents/MacOS/gimp: LibGimpBase-WARNING: gimp: gimp_wire_read(): error

(

I have no idea who travis is.

The plugins ls is:

^CMac-mini:plug-ins XXX$ ls -lhrt “$HOME/Library/Application Support/GIMP/2.10/plug-ins”
total 4040

-rwxr-xr-x@ 1 XXX staff 152K Nov 16 12:27 gimp-lqr-plugin-orig
-rwxr-xr-x@ 1 XXX staff 13K Nov 16 12:27 plug_in_lqr_iter-orig
drwxr-xr-x@ 3 XXX staff 102B Nov 16 12:28 LiquidRescale
-rwxr-xr-x@ 1 XXX staff 152K Nov 16 12:33 gimp-lqr-plugin
-rwxr-xr-x@ 1 XXX staff 13K Nov 16 12:36 plug_in_lqr_iter
-rwxr-xr-x@ 1 XXX staff 5.9K Dec 26 12:46 plugin-uncrop.py
-rwxr-xr-x@ 1 XXX staff 3.2K Dec 26 12:46 plugin-resynth-sharpen.py
-rwxr-xr-x@ 1 XXX staff 3.5K Dec 26 12:46 plugin-resynth-fill-pattern.py
-rwxr-xr-x@ 1 XXX staff 3.2K Dec 26 12:46 plugin-resynth-enlarge.py
-rwxr-xr-x@ 1 XXX staff 7.5K Dec 26 12:46 plugin-render-texture.py
-rwxr-xr-x@ 1 XXX staff 17K Dec 26 12:46 plugin-map-style.py
-rwxr-xr-x@ 1 XXX staff 3.1K Dec 26 12:46 plugin-heal-transparency.py
-rwxr-xr-x@ 1 XXX staff 6.5K Dec 26 12:46 plugin-heal-selection.py
drwxr-xr-x@ 3 XXX staff 102B Dec 26 12:47 ResynthesizerPlugin
-rwxr-xr-x@ 1 XXX staff 38K Dec 26 12:51 resynthesizer
-rwxr-xr-x@ 1 XXX staff 27K Dec 26 12:54 resynthesizer_gui
-rw-r–r-- 1 XXX staff 1.0M Dec 28 07:38 gimp-log.txt
-rw-r–r-- 1 XXX staff 546K Dec 28 07:44 gigimp-debug-tool-2.0
Mac-mini:plug-ins XXX$

I will try another fresh install today.


(Carmelo Dr Raw) #36

This explains all. Unfortunately my OSX plugins are only compatible with the official GIMP .dmg, not the one provided by Partha… this is due to some library incompatibilities that I have not been able to solve.


(Bob Cat) #37

Carmelo,

Thanks for sticking with me. I have done another fresh install. My third. I don’t know what went wrong on the first one but I was using just GIMP. The second install was with McGimp.

The third clean install was back to GIMP. And things are working again. Thank you.

One final question. On what menu do I find the liquid rescale?

Thanks for the help.


(Mica) #38

Generally in GIMP 2.10.x you can press the / key and start typing the name of thing you want. The box that appeared will search all the things in GIMP and return you the result.

  1. Press the / key.
  2. Type liquid or rescale.
  3. Select the menu item you desire
  4. ???
  5. PROFIT!!

(Carmelo Dr Raw) #39

Great!!! I am really happy to hear it works…

Liquid rescale should be available in the “layers” menu.