GIMP 2.9.5 AppImage


(Colin Paul Adams) #201

I just tried installing a gimp 2.9.2 from a copr provided rpm - it had both print-to-file and my printer showing, so it looks like the problem is in your AppImage (or else there’s been a reversion since 2.9.2).

BTW I use Fedora 24.


(Colin Paul Adams) #202

Sorry. That was 2.9.4 (-3.fc24.x86_64), not 2.9.2.


(Eduardo Bohoyo) #203

Thanks again; your latest version has improved the responsiveness of my drawing tools hugely :slight_smile:


#204

Hi all.

Thanks for the appimage it appears to working fine on my Mint Mate 18 install. I am getting the above warning each time I run the appimage though.
One other thing I noticed is there is no normalmap filter under Filters then Map. Will this be included in later versions as I tend to use it quite a lot for Blender normalmaps?


(Carmelo Dr Raw) #205

Have you tried selecting Verbose (layer name) in the Output mode… selector?

Here is what I get in this case:


(Mica) #206

I thought I had selected the correct option, but I will certainly check again, thanks!


(Carmelo Dr Raw) #207

Thanks for checking the appimage!

I am aware of this warning, but I have still not found the exact reason for this… is seems that the appimage runtime path is passed as a parameter when starting from the .desktop file.

The warning is harmless, just a bit annoying… hopefully I’ll soon find a fix.

Not all filters are included in the bundle, but I am open to suggestions. I will look into that.


(Mica) #208

Indeed it does work, sorry for the noise.


#209

@caz
Annoying messages, try in a terminal, check permissions and dot-slash to run

looks like this here : http://imgur.com/DzS5Jmt

NormalMap plugin
Not something I use, this one just compiled in an old laptop with Gimp 2.9.5 (otto ppa) installed.
http://s000.tinyupload.com/index.php?file_id=45872855889771520208
Remember to unzip, check permissions. It starts but not really tested.

For some reason if installed in the gimp profile ~/.config/GIMP-AppImage/2.9/plug-ins/ it does not register
so make a plugin folder and add in the preferences settings.
example: http://imgur.com/ZKEWe19

Some plugins work, some do not, so the usual guarantee, there is none


#210

Thanks for the info on the warning sign, it’s much appreciated, and thanks for looking into including the normalmap filter in future versions of the appimage.


#211

@rich2005

No luck with firing up the appimage via the terminal, I just get a ‘No such file or directory’ message when I try the command you posted.

Normalmap plugin works fine, thanks for that. I do also have the Crazy Bump plugin installed, it was copied over from my Gimp 2.8.16 profile when I installed the appimage, it too works fine. It’s a bit unwieldy though as it generates a lot of files.


#212

If the warning is not a problem when using a .desktop file then all is ok.
Best guess about command line. You do need to open the terminal in the same folder as the appimage. Otherwise enter the full path.


#213

Now ArchLinux (Aur) offers a working Gimp 2.5 (de87b0a) with Photoflow (0.2.7) plugin. Everything seems to work!

Thanks again to Carmelo_DrRaw !!

Less interested now by Gimp AppImage… I have no more excuse for not doing good ( at least well processed !!! ) images…


(Carmelo Dr Raw) #214

Good to know! The arch repositories seem to be among the most up-to-date…


#215

Thanks for the info. For whatever reason I wasn’t able to CD in terminal to the folder where I had placed the appimage, I had also forgot that I could just right click on the folder to open it in terminal. All’s fine now. Cheers.


(Sebastien Guyader) #216

I just tried the latest Gimp AppImage. I own a Fujifilm X-T1, and when I try to open a raw image from the camera, the preview is pink, and on closing there’s an error message saying that the RAF plugin could not open the image.
I guess it’s because X-Trans raw files are not supported by the Photoflow version shipped in the AppImage (0.2.6-pre). In installed the latest stabdalone version of Photoflow (0.2.7) and the X-T1 raws are supported.
Is it possible to include the latest version of the Photoflow plugin in the AppImage?


(Carmelo Dr Raw) #217

Yes, this is indeed in my plans for the next few days… I will try to make a new appimage version tomorrow.


(Carmelo Dr Raw) #218

I have just uploaded a new version of the GIMP AppImage, with BABL/GEGL/GIMP/GMIC/PhotoFlow all updated to their current git versions. As usual, the latest appimage can be downloaded from here.

Please let me know if you encounter any new issues with this new version.

Known problems:

  • missing printers in Fedora 24 (under investigation)
  • warning message when starting the appimage from the applications menu (again under investigation, the warning is annoying but harmless)
  • does not run on some Debian Jessie systems

(Mica) #219

If you’re considering plugins to include, please consider the save for web plugin.


(Carmelo Dr Raw) #220

Very good suggestion, I will include it in next bundle…