GIMP 2.9.5 AppImage


#301

@Carmelo_DrRaw yes, possibly libatk-bridge and more of ATK needs to be bundled.

Fwiw, gimp-cce-2.9.5-20170405.glibc2.15-x86_64.AppImage launches fine on ubuntu-gnome-17.04-beta2-desktop-amd64.iso.


(Joan Rake) #302

i give up with the appimage. does anyone know where the gimp 2.9.5 sources are and how i can install the resynthesiser plugin?


(Andrew) #303

I’m pretty novice with linux so found the official install stuff quite daunting. However there’s a ppa ottokesselgulasch (or otto-kesselgulasch maybe) which seems to work ok for me (2.9 5).


(Joan Rake) #304

this ppa only has g’mic.

i’m looking for gimp 2.9.5. i can’t install it from source because the dependencies aren’t working at all and i can’t seem to find some of them:

== Missing mandatory dependencies ==

GIMP configuration failed.
The following mandatory dependencies are missing:
  - babl >= 0.1.18
  - gegl-0.3 >= 0.3.8
  - atk >= 2.2.0
  - gegl
      *** Could not find gegl in your PATH.
  - gtk+-2.0 >= 2.24.10
      *** Test for GTK+ failed.
  - gdk-pixbuf-2.0 >= 2.30.8
  - gdk-pixbuf-csource
      *** Could not find gdk-pixbuf-csource in your PATH.
  - gexiv2 >= 0.6.1
  - libtiff
      *** Checks for TIFF library failed
  - libjpeg
      *** JPEG library not found
  - libjpeg
      *** JPEG header file not found
  - libjpeg
      *** JPEG library is too old
  - libbzip2
      *** libbzip2 header files not found
  - liblzma >= 5.0.0
  - lcms2 >= 2.6
  - Python 2 headers
      *** Please install them, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).
  - PyGTK 2.10.4 or newer
      *** Please install it, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).
  - pygtk-codegen-2.0 script
      *** Please install it, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).
  - PyCairo 1.0.2 or newer
      *** Please install it, or skip building the python scripting extension by
      *** passing --disable-python to configure (but then you will not be able
      *** to use scripts for GIMP that are written in Python).```

i’m honestly thinking about giving up here; i postulate that no-one will be able to help me with issues like these. tutorials are of no help.


(Carmelo Dr Raw) #305

Hi! First of all, sorry for replying so late, but I’m under heavy work load and catching up with messages and pending issues as fast as I can…

Before completely giving up with the AppImage, could you post the full list of error messages that you are getting? I seem to remember that the AppImage was working fine under Debian sid, so hopefully we can solve your problems easily…

Thanks!


(Joan Rake) #306

the errors that i get are from both the standard appimage and the appimage with more libraries.

this is one of the errors i’m getting; it occurs when i mount the appimage, move to /media/user/AppImage/usr/bin/ and run ./gimp. another is one which i have previously mentioned:


(Andrew) #307

Are you sure? If you look here https://launchpad.net/~otto-kesselgulasch there are various PPAs including 3 Gimp ones, I think I’m using gimp-edge (as I have system files with this in their name).


(Joan Rake) #308

thanks; this has the packages i’m looking for though now apt is complaining.

The following packages have unmet dependencies:
 gimp : Depends: libgimp2.0 (>= 2.9.5~99-0z0~ppa~257a4ce) but 2.8.20-1 is to be installed
        Depends: libgegl-0.3-0 (>= 1:0.3.14) but 0.3.8-3+b1 is to be installed
        Depends: libmypaint (>= 1.3.0-0z2~ppa) but it is not going to be installed
        Depends: libfontconfig1 (>= 2.11.94) but 2.11.0-6.7+b1 is to be installed
        Depends: libjasper1 but it is not going to be installed
        Depends: libjpeg8 (>= 8c) but it is not going to be installed
        Depends: libmng2 (>= 1.0.10) but it is not installable
        Depends: libwebkitgtk-1.0-0 (>= 1.3.10) but it is not going to be installed
 gimp-data : Depends: libgimp2.0 (= 2.9.5~99-0z0~ppa~257a4ce) but 2.8.20-1 is to be installed
E: Broken packages

(Carmelo Dr Raw) #309

You should not manually mount the AppImage and run the gimp executable. There is a special script that the AppImage runs when executed, which sets the proper environment before starting gimp. That’s needed in order to let gimp be linked with the bundled libraries at runtime, instead of the system-wide ones…

I would need to see the errors that you get when you run the appimage directly. In your previous post, you only quote

which does not show the full error log, just the very beginning…


(Joan Rake) #310

funnily enough, that is the full error log. the bit between .mount_ and ./DirIcon varies; that’s it.

i get another error when running it directly, namely: execv error: : No such file or directory.

here’s the result of me running the same command several times:

user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
Cannot open /tmp/.mount_E6PQ0P/.DirIcon
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
Cannot open /tmp/.mount_qFnufM/.DirIcon
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
Cannot open /tmp/.mount_YaNhWK/.DirIcon
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
Cannot open /tmp/.mount_xbbQKk/.DirIcon
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory
user@user:~/Downloads$ ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
execv error: : No such file or directory

where is this “script”?


(Carmelo Dr Raw) #311

This is really strange… I’m afraid I need the assistance of @probono here.

The errors like: /tmp/.mount_a4vT1N/.DirIcon are in fact the output of a pwd statement that is inserted at the very beginning of the usr/bin/gimp script used to properly invoke GIMP.

@probono: do you have any idea why .DirIcon (which is a file, not a directory) is printed by the pwd statement in Joan’s case?

It is part of the code embedded in the AppImage package itself, as far as I understand, so it is not “visible”.


#312

Hi @Carmelo_DrRaw, let’s have a look:

wget https://pixls.us/files/gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage
sudo mount ./gimp-2.9.5-20170310.glibc2.15-x86_64.AppImage /mnt
/mnt/AppRun 
./bin//gimp.wrapper: line 89: /mnt/usr/bin/gimp: Permission denied

So the binary inside the AppImage was not executable, which is easy to fix…

cp -r /mnt/ gimp-2.9.5-20170310.glibc2.15.AppDir
sudo chown -R $USER gimp-2.9.5-20170310.glibc2.15.AppDir/
./gimp-2.9.5-20170310.glibc2.15.AppDir/AppRun

Runs!


(Carmelo Dr Raw) #313

The difference I see is that the other binaries in the usr/bin folder are executable by everybody, while gimp is only executable for the user… I will fix this, however I am not sure that this will solve the specific problem reported above, i.e. that upon execution, a pwd statement at the very beginning of the usr/bin/gimp wrapper script returns

/tmp/.mount_a4vT1N/.DirIcon

instead of

/tmp/.mount_a4vT1N/usr

as it should… any idea how to debug this?

Thanks!


#314

No, as I don’t get this error…


(Joan Rake) #315

i tried the steps here once and i got this gigantic string of errors.


(Joan Rake) #316

moved to lubuntu xenial; i’m getting the same errors.


(Carmelo Dr Raw) #318

I will run a lubuntu xenial live cd and see if I can reproduce the error…


(Joan Rake) #319

my mistake, i’m on xubuntu and i’m updating to yakkety. should be mostly the same.


(Mica) #320

Xubuntu is a flavor of Ubuntu with XFCE, yakkity is a release. Maybe you mean xenial -> yakkity?


#321

I deleted that previous post because I was just reiterating earlier comments from various posts.

example: from long list of errors

Not the way to start an appimage.

A new day and I see xubuntu is being used so here is a little video running the appimage, start to finish including comments, 3 minutes. It might help

That is xubuntu 16.04 (Xenial)

I can even get the appimage running in PClinuxOS KDE, an rpm based rolling distro. Compatibility is never guaranteed but it is always worth a try.