GLib-GIO-CRITICAL messages when running darktable

Hello all,

Running DT from the command line I get two error messages as in the title:

(darktable:37534): GLib-GIO-CRITICAL **: 11:37:55.159: GFileInfo created without standard::is-hidden

(darktable:37534): GLib-GIO-CRITICAL **: 11:37:55.159: file ../glib/gio/gfileinfo.c: line 1633 (g_file_info_get_is_hidden): should not be reached code here

These are repeated over and over for so long as I have DT open. They are the same whether opening DT with

~]$ darktable --disable-opencl

or

~]$ darktable -d opencl

Can anybody tell me what they mean? Obviously denoting a problem but where? Which files should I examine? What to post in order to get further help?

OS is Arch Linux, self-built PC with AMD GPU and CPU. 32Gb RAM so little need for OpenCL.

The problem is that I cannot import film rolls (folders/directories). I click on Import > Add to library, the add to library interface opens and shows a list of folders within my home directory but it is hung. Nothing opens or moves if I click on it. Completely stuck.

I think deciphering those two lines will help me get started. Any other pointers also appreciated.

Hi, I don’t think those errors are of any consequence, they’re GTK errors.

What version of darktable are you running and where did you install the package from?

I see you’re running arch, did you just get some GTK updates?

1 Like

Thank you for the response Mica. Indeed that is what they are. Searches show these messages are sometimes a flag that something is going wrong with another package although often, as you say, nothing to worry about. Difficult to pin down.

So it may be a red herring. I first reported it on the Arch forums more than a month ago. But it has been happening since long before then.

Arch is a rolling distro and I update mine weekly. So I always have the current stable release of DT, currently 4.4.2. It was initially installed from the Arch repos and is updated with each new release as it reaches the repos.

OpenCL does appear to be running OK without any problems. running DT with darktable -d opencl -d perf tells me what a wonderful job it is doing, with no hint of errors.

So I can’t get any clues as to why DT is hanging when I try to import a film roll. It is costing me an inordinate amount of time and constant frustration. I really need that function working or I cannot function.

I did a shoot on Wednesday and tried to upload it as soon as I got home. I finally uploaded it late last night after hours of trying. The Import > add to library worked for that one film roll then jammed again. I still have many film rolls on the hard drive, copied from the old PC, to import since building this machine late last year. Progress is excruciatingly slow.

This has now been going on for many months. I have tried each OpenCL driver in turn. The only problem I can identify, apart from the retouch module throwing artifacts intermittently but lots of users report that one, is the import module.

My current thoughts are that after all this, OpenCL is not causing the problem. But I don’t know where else to look nor how to begin any process of testing to find out.

fixed already in master imports: Fix error in attributes. · darktable-org/darktable@3e969b2 · GitHub

1 Like

Looks good, thank you. When is that likely to appear in a DT stable update or stable release?

Most importantly, is it likely to fix my import problem? That is the current bane of my life.

Otherwise, can you tell me what steps to take to discover what is causing that problem?

xmas, no, no idea

perhaps this issue report for GNOME is also relevant?

1 Like

Yes. The error message is identical and I’ve seen others on github. GNOME, GNOME Manager and Flatpak have joined my list of possible suspects so far. But are any of them actually doing something which causes a problem or are the messages meaningless? In which case all they do is make me scroll through pages of irrelevant error messages in between genuine data.

Another possible line of enquiry is my DT settings. I can’t see anything wrong in there but I am not a programmer, let alone a seasoned DT developer. Most of DT’s entrails simply confuse me.

The issue report I linked shows that the issue is at the Gtk level.

BUT: that issue report is for Gtk2, I found out a bit later that darktable uses Gtk3. So I’m not too sure it’s directly relevant.

OpenCL has nothing to do with import. It is only used in processing modules.

You likely need to do darktable -d common and try to import.

Why are you using arch?

1 Like

g-man that is the most useful reply I have received, here or on the Arch forums, since this problem arose. The -d common flag hasn’t worked but at least I can now dismiss OpenCL from my enquiries altogether.

In fact I am pretty well convinced that a side effect has been that OpenCL is now active and working properly on my system so at least something good has come out of it all.

Why am I using Arch? Rolling distro. I got tired of packages being outdated prior to a next full release on other distros, then having to find an unlisted repo to be able to use, e.g. a browser.

Now I have a defunct, albeit dated and a bit underpowered for today’s image manipulation needs, PC available I may try Tunbleweed, the Open SuSE rolling version, but having been with Arch for somewhere around a decade, possibly longer, I am unlikely to move. I have found problems to be more easily surmountable and maintenance less demanding than anything else ever.

-d common should work. What version of darktable are you using? Darktable --version

As in my earlier reply. That’s the whole point of a rolling distro.

I don’t remember which version it was on when I first installed it.

What? Are you using the DT flatpak? If not, then flatpak has nothing to do with it. If you are using flatpak, you should’ve mentioned that many many posts ago.

Where do you store your photos? Are you sure your user has permissions to that folder? Is it an external disk? Local disk? How is that disk mounted?

1 Like

@Mica you’re ‘avin’ a larf! (London accent in case you’re not familiar with it - having a laugh).

I am not aware of “using” anything other than the headline names of the software. When I look under the bonnet, or go wandering around the web to see if I can find what’s going wrong, I find all sorts of things I can only take to be standard for the installation either of the operating system r of the package in question without any idea as to what most of them are.

Until today’s searches I’d thought of flatpack (note the letter c) as an Ikea institution, possibly even more intractable than problem solving DT.

flatpak is listed when querying contents of ~/.local/share/ at the next level down, but not under the darktable directory. Does that mean I am “using” it?

I don’t know. But flatpak has come up several times in github and in mentions of DT in searches in the context of the GTK errors.

As for mentioning it, I wasn’t even aware of it. I still don’t know what it does or what it is supposed to do.

I’ve deleted the GTK errors, there were pages of them, but here is the output from darktable -d common. I can’t spot any clues in there. Can anybody else?

~]$ darktable -d common
     0.0172 application_directory: /usr/bin
     0.0300 darktable.datadir: /usr/share/darktable
     0.0300 darktable.plugindir: /usr/lib/darktable
     0.0300 darktable.localedir: /usr/share/locale
     0.0301 darktable.configdir: /home/gomi/.config/darktable
     0.0301 darktable.cachedir: /home/gomi/.cache/darktable
     0.0301 darktable.sharedir: /usr/share
     0.0301 darktable.tmpdir: /tmp
     0.0301 new_xdg_data_dirs: /usr/local/share/:/usr/share/
     3.9374 [dt_worker_threads] using 4 worker threads
     4.5063 [dt_get_sysresource_level] switched to 1 as `default'
     4.5064   total mem:       31438MB
     4.5064   mipmap cache:    3929MB
     4.5064   available mem:   15719MB
     4.5064   singlebuff:      245MB
     4.5064   OpenCL tune mem: OFF
     4.5064   OpenCL pinned:   OFF
[opencl_init] opencl related configuration options:
[opencl_init] opencl: ON
[opencl_init] opencl_scheduling_profile: 'default'
[opencl_init] opencl_library: 'default path'
[opencl_init] opencl_device_priority: '*/!0,*/*/*/!0,*'
[opencl_init] opencl_mandatory_timeout: 400
[opencl_init] opencl library 'libOpenCL' found on your system and loaded
[opencl_init] found 1 platform
[opencl_init] found 1 device

[dt_opencl_device_init]
   DEVICE:                   0: 'gfx90c:xnack-'
   PLATFORM NAME & VENDOR:   AMD Accelerated Parallel Processing, Advanced Micro Devices, Inc.
   CANONICAL NAME:           amdacceleratedparallelprocessinggfx90cxnack
   DRIVER VERSION:           3590.0 (HSA1.1,LC)
   DEVICE VERSION:           OpenCL 2.0 
   DEVICE_TYPE:              GPU
   GLOBAL MEM SIZE:          512 MB
   MAX MEM ALLOC:            384 MB
   MAX IMAGE SIZE:           16384 x 16384
   MAX WORK GROUP SIZE:      256
   MAX WORK ITEM DIMENSIONS: 3
   MAX WORK ITEM SIZES:      [ 1024 1024 1024 ]
   ASYNC PIXELPIPE:          NO
   PINNED MEMORY TRANSFER:   NO
   MEMORY TUNING:            NO
   FORCED HEADROOM:          400
   AVOID ATOMICS:            NO
   MICRO NAP:                250
   ROUNDUP WIDTH:            16
   ROUNDUP HEIGHT:           16
   CHECK EVENT HANDLES:      128
   PERFORMANCE:              0.584
   TILING ADVANTAGE:         0.000
   DEFAULT DEVICE:           NO
   KERNEL BUILD DIRECTORY:   /usr/share/darktable/kernels
   KERNEL DIRECTORY:         /home/gomi/.cache/darktable/cached_v1_kernels_for_AMDAcceleratedParallelProcessinggfx90cxnack_35900HSA11LC
   CL COMPILER OPTION:       -cl-fast-relaxed-math
   KERNEL LOADING TIME:       0.1340 sec
[opencl_init] OpenCL successfully initialized. Internal numbers and names of available devices:
[opencl_init]		0	'AMD Accelerated Parallel Processing gfx90c:xnack-'
[opencl_init] FINALLY: opencl is AVAILABLE and ENABLED.
[dt_opencl_update_priorities] these are your device priorities:
[dt_opencl_update_priorities] 		image	preview	export	thumbs	preview2
[dt_opencl_update_priorities]		0	-1	0	0	-1
[dt_opencl_update_priorities] show if opencl use is mandatory for a given pixelpipe:
[dt_opencl_update_priorities] 		image	preview	export	thumbs	preview2
[dt_opencl_update_priorities]		0	0	0	0	0
[opencl_synchronization_timeout] synchronization timeout set to 200
[dt_opencl_update_priorities] these are your device priorities:
[dt_opencl_update_priorities] 		image	preview	export	thumbs	preview2
[dt_opencl_update_priorities]		0	-1	0	0	-1
[dt_opencl_update_priorities] show if opencl use is mandatory for a given pixelpipe:
[dt_opencl_update_priorities] 		image	preview	export	thumbs	preview2
[dt_opencl_update_priorities]		0	0	0	0	0
[opencl_synchronization_timeout] synchronization timeout set to 200
     7.4662 [dt_worker_threads] using 4 worker threads
 133.9544 Session fullpipe cache report. hits/run=0.00, hits/test=0.000
 [opencl_summary_statistics] device 'AMD Accelerated Parallel Processing gfx90c:xnack-' (0): NOT utilized


Most of it is about OpenCL. The rest is just a few lines at the top. I can see nothing in there to offer a hint.

Can you answer these questions too please?

Did you try to do an import while using darktable - d common?

1 Like

ROTFL Yes, and the import function was jammed.

Mica, I have direct access (permissions) to all files in the sole user (me) directory on this computer. I store all the image files on this computer in the same user space I use for everything else. I can also su to root with a few keystrokes.

I’m not in the habit of ignoring questions. Not intending to be rude but if I don’t reply you can assume it’s my own home directory or the question asked is answered within the question itself.