Gmic 1.7.5 and gimp_dreamsmoothing command line?


(bill) #1

Did i have missed something? i tried a lot of time with this command line gimp_dreamsmoothing but without success, where is the error please:

gmic input -gimp_dreamsmoothing 10,1,1,1,0,0.8,0,24,1,0 -o output


(Mica) #2

If you also have the gimp installed, change the gmic output to verbose and it will spit out the command it uses.


(David Tschumperlé) #3

Command -gimp_dreamsmoothing does not exist, but -gimp_dreamsmooth does:

$ gmic input.jpg -gimp_dreamsmooth 10,1,1,1,0,0.8,0,24,1,0 -o output.jpg

works for me.


(bill) #4

I updated right now my version to 1.7.6, but i still have the same error with the new command -gimp_dreamsmooth


(Pat David) #5

is your command missing a ...,1,0 at the end?


(bill) #6

no, the right command seems to be with: 10,1,1,1,0,0.8,0,24


(Pat David) #7

Did you run gmic --update after upgrading? It is working fine for me on a fresh install from gmic.eu.


(David Tschumperlé) #8

I suggest you update your commands once to be sure you get the -gimp_dreamsmooth command available:

$ gmic -update

Then it should be OK.


(bill) #9

Yes with -update it works now

Thank you patdavid, thank you David :slight_smile:


#10

Hi everybody, this is my first post in this community!! :smile:

I’m sorry for resurrecting this thread, but I’m having the same issue as Bill -“Unknown command or filename ‘-gimp_dreamsmooth’”- and I have the following configuration:

  • Ubuntu 16.04 Xenial
  • GMIC 2.0.5 - installed from the package of the official page - previously from the Ubuntu packaging, then updated to the official one and used “gmic --update”
  • No GIMP: I’m running this on a remote ssh Shell :wink:

By the way, I don’t understand why this command ‘-gimp_dreamsmooth’ is not documented in the official Reference , am I missing something?

Have a Nice Day,
Enrico


(Karsten R) #11

Hi Enrico,

the functions used in Gimp have been renamed since version 2.0.0 . Maybe you should look for ‘-fx_dreamsmooth’.

Anyway, the interface functions of gmic used in Gimp are rarely documented with the gmic cli help system. You should look into the Gimp plugin to understand its function and parametrization. The “official reference” shows only the documentation of cli functions, not the relatively volatile Gimp interfacing functions.

The functions are defined in update205.gmic to be found with
gmic -e \$_path_rc

Regards
Karsten


#12

Hi Karsten!! Yeah, with the right name I even found the source file :laughing:

Thanks for the heads-up, Enrico