G'MIC Mandelbrot Filter Error

Hi Everyone,

While using the G’MIC Mandelbrot / Julia filter, my wireless mouse seemed to randomly change the filter settings, I simply turned it off and on again which resolved that problem, but when clicking OK I now receive this message “Error in ./fx_mandelbrot/ *** Command ‘input’: File ‘0’, format does not take any input options (options ‘0’ specified).” could someone please help me try to resolve the issue.


Welcome @pypedreams

I tried to reproduce this by pushing all settings to extremes, but it always works. Can you please tell us which OS and g’mic version you’re using?

Some basic things to try otherwise:

  • try the latest stable version if not already
  • try pressing the filters update button
  • if you use a “fave”, try working with the filter in the main tree instead

I’m using Windows 10, and the latest version of G’MIC 3.1.6. I’ve already tried pressing the filter update button, which hasn’t resolved the issue. The wireless mouse was definitely the cause.

Thanks, this is quite strange to say the least. I tried switching to 3.1.6 and still unable to reproduce the problem, but then I’m on linux and haven’t used g’mic on windows for years.

If I get time, I’ll try on a virtual machine. Otherwise, lets hope a windows g’mic user comes along with some ideas. My first instinct would be to uninstall g’mic and remove all trace, then reinstall. That might not be as simple as it sounds - I’m not certain where the “update316.gmic” update file lands on windows.

Edit: be aware you could lose “favs” by doing an uninstall + cleanup

1 Like

At the G’MIC command line, I can simulate some aspects of @pypedreams error message thus:

$ gmic -debug 0,0
[gmic]-0./ Start G'MIC interpreter (in debug mode).<gmic>-0./ Initial command line: 'cli_start , -debug 0,0'.
<gmic>./ Decompose command line into 4 items: 
<gmic>./   item[0] = 'cli_start'
<gmic>./   item[1] = ','
<gmic>./   item[2] = '-debug'
<gmic>./   item[3] = '0,0'
<gmic>-0./ Enter scope './'.
<gmic>-0./ Item[0]: 'cli_start', selection [].
<gmic>-0./ Found custom command 'cli_start: ' (takes no arguments).
<gmic>-0./ Expand command line for command 'cli_start' to: ''.
<gmic>-0./cli_start/ Return from empty command 'cli_start/'.
<gmic>-0./ Item[2]: '-debug' -> 'debug', selection [].
<gmic>-0./ Item[3]: '0,0', selection [].
<gmic>-0./ Command 'input': arguments = '0,0'.
[gmic]-0./ Input file '0' at position 0
[gmic]-0./ *** Error *** Command 'input': File '0', format does not take any input options (options '0' specified).

In English: G’MIC, when it cannot designate any incoming item as a command, punts and assumes the presence of an implicit input command; the next item in the stream is taken to be an argument list to input. In the simulation, the next item is taken to be an argument list: 0,0. The first argument, 0 plays: to the input command, this calls for the creation of an empty image (image metadata without image data, useful for some purposes) This particular image format does not take image format options, which is what the second argument, also 0, purports to be. Having been given an input option for a format that does not take any, G’MIC throws the observed exception.

My suspicions run along the lines that this event introduced nonsense into your gmic_qt_faves.json. Normally gimp/gmic_qt manages the content of this file without user intervention, so that filter settings may conveniently persist from use to use. Of course nonsense, if it gets in there, persists as well, which, to me, explains that the Mandelbrot filter no longer seems to work. The nonsense so introduced has, in part, put in place a pair of zeros separated by a comma — and maybe more, and is being taken as an argument list to an implicit input command. If this theory of mine has any legs, then moving/renaming/deleting this possibly corrupt .json file should cure the problem — and delete all of these conveniently kept and possibly corrupt settings. See the GimpChat discussion linked in above for particulars of finding this file. Being a .json file, you can look at it with a text editor and, perhaps, find the nonsense that is the source of your difficulty.

Let us know if this works out.

Hi Gary,

Following the advice below, seemed to resolve the Mandelbrot / Julia filter issue:

Make sure to use the latest version of G’MIC and then press the filter update button.

Once G’MIC is updated make sure any out-of-date files are removed. Delete the folder C:\Users"yourname"\AppData\Roaming\gmic A new default one is made when you next run gmic.

It is a bit like Gimp, any screwed up settings are held in the profile.

On the other hand, since it is mouse related, it might be a Gimp problem. The mouse settings are saved it the file:

C:\Users"yourname"\AppData\Roaming\GIMP\2.10\devicerc You could back that up (…devicerc-bak) Gimp will make a new default devicerc when next started.

Just be clear, you need to delete the gimc file that comes after “roaming” and then devicerc file that comes after “2.10”.

So, you are off and running, no? Good to hear, if so. Welcome to the board. Hope you find other stuff here useful and/or amusing. Take care.

Yeah, the filter seems to working, as I’ve recently produced several Mandelbrot images. Thanks for the help.