GMIC Mosaic - how to prevent resizing

I’m in GIMP if it matters.
I’m trying to prevent the resizing of the individual images but can’t seem to do it correctly.
I have 557 images that are 50 to 262 pixels wide and all are 120 pixels tall. When I do the montage it still resizes some to be smaller. Centering / scale is set to 0.5 which I thought prevented scaling but it doesn’t seem to. Set montage type to “auto” none of the images are still 120px tall. Some are down to 3px tall but all have been reduced at some point. Changing from auto to horizontal or vertical array generates a “too many input images” preview error and the same if I try to apply/ok. Merging mode is set to scaled but if I change it to aligned they don’t stay aligned. Auto displays them but breaks them up however the H and V array options still give the same error message.

Additional info
100+ seems to be the magic number where I get “too many input images” when doing an array, which prevents resizing but also is ~450 too few images. :frowning:

@rodgerw Welcome to the forum! Could you tell us which montage or mosaic filter you are using? G’MIC has many.

@afre oops, sorry I thought I had included everything!
I’m uncertain what is missing so does this answer it?
Complete steps are
File -> new (default options, no template selected) -> OK
File -> open as layers, select images then Open (and wait a bit)
Filters->GMIC-qt(2.9.4)
Arrays & Tiles -> Montage
Type and merging modes as above -> auto, horizontal or vertical array and Scaled or Aligned (though Aligned limits the number of images to fewer than 100 - error above. Scaled doesn’t limit images but reduces the size of every single image)

Thanks. I rarely use Montage and never with so many images. (My machine can’t handle much to begin with.) I will defer to other people. @David_Tschumperle @Reptorian etc.

That’s a official command by @David_Tschumperle. It’s up to him if he wants to add prevention of resizing. In addition, I can’t do anything about error message.

Can you confirm the issues?