G'MIC plugin installed, working, with exception of Repair

I’ve installed G’MIC on two different laptops, One W7, the other W10.

I’ve successfully applied a couple of effects but when I try to “repair” I can’t get it to function. I’ve tried all manner and combinations of layers, select, un-select, etc.

It’s gotta be something I’m not doing correctly. Is this a common issue for Noobs like me?


Repair is the name of a folder, not a filter.
Could you tell us what filter in Repair did you try ?
And with what version of G’MIC and GIMP ? Thanks.


Thank you for the response.

Almost immediately after posting I realized what you pointed out – should have gone back
and edited the post. My aplogy for that.

GIMP 2.10.12 and G’MIC 2.10.

The specific tool is “inpaint”. I tried the patch-based and one other. No preview, and when
clicking apply the progress slider would animate for a second and then cease.


Welcome to the forum!

Inpaint in general is resource heavy, so may be too much for your memory to handle. Try doing it on very small images or selection first to see if it works.

I suspected as much. That’s one reason I tried it on the Win 7 unit. It’s not the greatest but it is i5, 10Gigs RAM. The other is definitely on the short side.