Haldclut problem on fedora

(Pupoje A) #1

I have problem with haldclut film simulation on fedora 25/26.

I can select the filter for the first time of use. But if I try select the filter for the second time, I can’t.

It simply doesn’t appear.

Example. I select under color - Fuji - Fuji Astia.
I works, but if I go to color - Fuji for the second time, I doesn’t show any Fuji filters. I see only color - Fuji folder and that’s all.

I have the same issue on three others laptops, so it’s not hardware related.

I think it has something to do with Wayland in fedora.
Because if I log out and log in again but with gnome xorg, everything works perfect


Hi @Pupoje_a and welcome!

What RT version are you using?

Have fun!
Claes in Lund, Sweden

(Pupoje A) #3

Hi Claes. Im using the rt version 5.3

i’ve uploaded some video to demonstrate this problem


you can see how the fuji and three other filter are simply not displayed.
the last filter appears for the moment, but the second time i’ve went with the mouse over, i just doesnt appear any more



Thanks for the video.
Yes, I see the problem.
Please let me think for a while…

Claes in Lund, Schweden

(Morgan Hardwood) #5

@Pupoje_a hi, thanks for the video!

This is probably a GTK+ issue, something which needs to be fixed upstream, not by us. Please report it here: https://bugzilla.gnome.org/enter_bug.cgi?product=gtk%2B

But I’m curious.
I see that previously used sub-menus did not open when you hovered, but what if you click on a previously-used sub-menu, does it still not open?
Please paste the contents of Preferences > About > Version, and tell us which version of GTK+ you’re using.

In the future, please use https://filebin.net/ for sharing files - it’s free, clean and fast.

(Pupoje A) #6

Ok, this is content of “About” from Raw Therapee

Version: 5.3
Branch: 5.3
Commit: ec0f7936
Commit date: 2017-09-30
Compiler: cc 7.1.1
Processor: x86_64
System: Linux
Bit depth: 64 bits
Gtkmm: V3.22.0
Lensfun: V0.3.2.0
Build type: release
Build flags: -O2 -g -pipe -Wall -Werror=format-security -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64 -mtune=generic -std=c++11 -Werror=unused-label -fopenmp -Werror=unknown-pragmas -Wall -Wno-unused-result -Wno-deprecated-declarations -O2 -DNDEBUG
Link flags:
OpenMP support: ON
MMAP support: ON

And Fedora ist using gtk 3.22 version
About Submenu. Nothing happens, hovering or even clicking on it.



Since last time I have installed Fedora 26 and RT 5.3 on a spare SSD to see for myself what happened.
I believe that Morgan is right in his hypothesis about GTK+ problems. Please follow his advice.

Claes in Lund, Schweden

(Morgan Hardwood) #8

Duplicate of #3967