Help with darktable gimp.lua script


#1

Hello,

I’m running darktable 2.4.4 on my Windows 10 computer. I’ve finally gotten the gimp.lua script to work but I’ve run into a problem. I’m trying to export a 32bit TIFF image from darktable to GIMP but after opening I get an error stating:

Opening ‘C:\Users[Username]’ failed: Unknown file type

Opening ‘C:\Program Files\darktable\Family\AppData\Local\Temp\Untitled.tif’ failed: Error opening file C:\Program Files\darktable\Family\AppData\Local\Temp\Untitled.tif: No such file or directory

The problem is that those locations don’t exist on my computer. Also gimp.lua saves the TIFF files in the original folder locations but I can’t open them. My computer doesn’t recognize the file type.

Any help would be greatly appreciated.


#2

Do you use the Partha version of Gimp? I wasn’t successfull with it, too, but had no problems with the original GIMP 2.10.


#3

No I downloaded the original version. I don’t think the problem is with GIMP though; I can open files just fine with it alone.


(Tobias) #4

Are you able to open this file file with gimp after exporting it with darktable?


#5

Correction, yes the TIFF file produced can be opened with GIMP. So there’s a bit of a disconnect with GIMP looking at the wrong place for the file?


#6

It’s not a deal-breaker for me in my decision to switch out from the Adobe-sphere but fixing this would speed up my editing a bit. Any help would still be appreciated.


(Mica) #7

What version of GIMP are you using?


#8

Version 2.10.2


(Bill Ferguson) #9

When darktable exports the images it creates an image table and passes that to gimp.lua. gimp.lua simply opens the files that darktable let it know about. What was the name of the file that you selected to export? On windows the normal export directory is C:\Users<username>\AppData\Local\Temp.


#10

The name of the file was Untitled.tif. That’s what I think the problem is: the lua script is directing GIMP to look at the wrong place and I don’t know enough about lua to change the directory. The script is directing GIMP to a directory that doesn’t exist on my computer and maybe changing it would help.


(Bill Ferguson) #11

The script is looking where darktable says it put the file when it exported it. Do you know where the file actually ended up?


#12

Yes it got put into the same folder as where the original is.


(Bill Ferguson) #13

Can you start darktable from the command line and add -d lua as an argument then paste the resulting output so that I can see what is going on?

Thanks


#14

I’ll get the info as soon as I get home. Thanks for helping!


#15

Ok I ran darktable -d but I can’t find the debug file. I check C:\Users[username]\AppData\Local\Microsoft\Windows\INetCache\darktable\darktable-log.txt but that file isn’t there. I also checked the \Local\darktable folder but nother was there either.

Where would I find the debug file?


(Bill Ferguson) #16

It appears something has changed since those instructions. I just tried

c:“program files”\darktable\bin\darktable -d lua > log.txt

and it actually wrote to the log file that I redirected to. So, give that a try.


#17

Thanks Bill, I’ll take a look again later.


#18

Sorry for the long delay; had gone on a vacation in the meanwhile. I tried running darktable from the command line again with the changes suggested but still not log. In the meanwhile, I decided to just stick with the current workflow where I just make TIFF files before importing to GIMP; at least this way I can put the files into a common folder and trash it when I’m done.

Thanks again for the help!