Huston, we have a problem

dt 3.6.1 (from obs) on opensuse leap 15.3.

Here’s my export:

dogs-vancouver-20130622-7433_01

Here’s was dt screenshot

The same thing happens when I export:

  • file on disk
  • rl output sharpen

What happened?

Thanks

What your your export settings look like…sometimes unintended entries there can create an issue…

opencl? what GPU?

Just my regular settings and never had a problem before

AMD Ryzen 7 with renoir built-in. No opencl. Renoir only has 512MB dedicated so no opencl. I’ve not even installed it on this laptop

This is a wrong stride size at output. Looking at the diagonal, the row is lacking 1 px, so the next row begins 1 px too early, at the end the previous one.

Please state the whole export settings (format, size) and the original size of the file. Try exporting at 1:1 and report.

It’s a Canon 7D cr2: size: 5202(5360)x3464(3516), exported a jpeg quality 70

  • When exporting full size: OK
  • When exporting height of 1000 pixels: OK
  • When exporting height of 675 pixels: problem

Thanks

So there is an inconsistent rounding error in the pixel count somewhere. Please report the bug on Github. I suspect the sizes are rounded several times at several places and one of them is 1 px shorter than the others.

i would bet the problem could go away by just making the export height divisible by 2. so maybe just going to 676 might fix it.

1 Like

Hide it, not fix it. Although it’s true that no real device uses an odd number of pixels anyway.

No it doesn’t. This is very specific to 675 pixels height.

  • 676 pixels height: ok
  • 685 pixels height: ok
  • 665 pixels height: ok
  • 673 pixels height: ok
  • 677 pixels height: ok

It’s not specific to this image. I tried some other images, same setting: width: 0 and height: 675. Only the portrait/vertical images gets the crooked/sheared look, not the landscape/horizontal images and only at 675.

Thanks

Like @aurelienpierre said , please report it on GitHub so it’s reported as an official bug that can be fixed .

I’d like to, but github won’t let me create my account.

I can provide with all the information (including the files) you need/want to file the bug.

Thanks

FYI I tried reproducing the error using your same export settings but didn’t encounter your issue

I can confirm I can’t get this to happen on my machine…WIndows version…could it be a driver issue??

in DT with the export settings and the modules used. This one is B&W.

the exported image

Only happens on verticals and height of 675px with either the rl sharpening or the straight file on disk.

Sorry, but I don’t know what you mean by rl sharpening or strait file from disk. Perhaps I’m being dense. I do have a Github account, so I can help submit a report if I can reproduce your problem. I had a similar issue a while back where it was clear a problem existed but no one could reproduce it, so I feel your pain.

Perhaps some more details…

That is a Lua script the point is I don’t see it so its not universal or its a 3.6.1 problem…I am long past that version…it could still be something related to the OP drivers or video config…or that version of Linux or … or… but I don’t think its universal unless others chime in so it may not even be a bug…

dt 3.7.0+1514~g9203ea3e1
linux 5.4.0-90-generic
Ubuntu 20.04
export → target storage → “file on disk”
OpenCL : activated

clinfo
(...)
Platform Name                                   NVIDIA CUDA
Number of devices                                 1
Device Name                                     GeForce RTX 2060
Device Vendor                                   NVIDIA Corporation
Device Vendor ID                                0x10de
Device Version                                  OpenCL 1.2 CUDA
Driver Version                                  460.91.03
Device OpenCL C Version                         OpenCL C 1.2
(...)

Not able to reproduce …
Did you make sure your issue is not related to your image viewer ?

  1. There are various export capabilities through the down arrow/triangle: output sharpening

Screenshot_20211125_080247

file on disk

Screenshot_20211125_080310

  1. Here’s my inxi & darktable
$ inxi -Fzx
System:    Kernel: 5.3.18-59.34-default x86_64 bits: 64 compiler: gcc v: 7.5.0 
           Desktop: KDE Plasma 5.18.6 Distro: openSUSE Leap 15.3 
Machine:   Type: Convertible System: LENOVO product: 81X2 v: IdeaPad Flex 5 14ARE05 
           serial: <filter> 
           Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <filter> UEFI: LENOVO 
           v: EECN36WW date: 05/17/2021 
Battery:   ID-1: BAT0 charge: 31.3 Wh condition: 52.5/52.5 Wh (100%) 
           model: Celxpert L19C3PD6 status: Unknown 
CPU:       Topology: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP 
           arch: Zen rev: 1 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
           bogomips: 31938 
           Speed: 1397 MHz min/max: 1400/2000 MHz Core speeds (MHz): 1: 1397 2: 1397 3: 1397 
           4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 
Graphics:  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus ID: 04:00.0 
           Device-2: Syntek Integrated Camera type: USB driver: uvcvideo bus ID: 1-4:4 
           Display: x11 server: X.org 1.20.3 driver: amdgpu,ati 
           unloaded: fbdev,modesetting,vesa resolution: <xdpyinfo missing> 
           OpenGL: renderer: AMD RENOIR (DRM 3.39.0 5.3.18-59.34-default LLVM 11.0.1) 
           v: 4.6 Mesa 20.2.4 direct render: Yes 
Audio:     Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel v: kernel 
           bus ID: 04:00.1 
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
           driver: N/A bus ID: 04:00.5 
           Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 04:00.6 
           Sound Server: ALSA v: k5.3.18-59.34-default 
Network:   Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter vendor: Lenovo 
           driver: rtw_8822ce v: N/A port: 2000 bus ID: 02:00.0 
           IF: wlan0 state: down mac: <filter> 
           Device-2: Realtek RTL8153 Gigabit Ethernet Adapter type: USB driver: r8152 
           bus ID: 2-1.4:3 
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 88.94 GiB (18.6%) 
           ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLB512HBJQ-000L2 size: 476.94 GiB 
Partition: ID-1: / size: 74.31 GiB used: 8.26 GiB (11.1%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home size: 383.81 GiB used: 80.67 GiB (21.0%) fs: xfs dev: /dev/nvme0n1p3 
Swap:      ID-1: swap-1 type: partition size: 16.44 GiB used: 0 KiB (0.0%) 
           dev: /dev/nvme0n1p4 
Sensors:   System Temperatures: cpu: 31.0 C mobo: 21.0 C gpu: amdgpu temp: 23 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 242 Uptime: N/A Memory: 15.01 GiB used: 829.3 MiB (5.4%) Init: systemd 
           runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.23 inxi: 3.1.00 


$ rpm -q darktable
darktable-3.6.1-lp153.31.1.x86_64

I do not have opencl installed since DT will not benefit from it.

  1. I can provide the original photos and the xmps if needed.

  2. The problem is only with MOST verticals with a height of 675 pixels, but changing it to 676 pixels or 674 solves my problem and 3.8 is just around the corner. Whatever my problem is (which is minor in grand scheme), it could be already fixed in the next version.

Thanks