I'm unable to run Rawtherapee developer versions in Windows any more...

Hi,

Something probably went wrong with automatic builds of developer versions of Rawtherapee in Github. I tried to run RT_dev_5.8-2330 and RT_dev_5.8-2334 (both extracted from zip packages, in Windows 10 x64) and twice get an error (in Polish):

“Nie można kontynuować wykonywania kodu, ponieważ nie znaleziono obiektu libssp-0.dll. Ponowne zainstalowanie programu może rozwiązać ten problem.”

Which in English is - according to Google Translate:

“The code cannot continue because the libssp-0.dll object was not found. Reinstalling the program may fix this problem.”

I checked twice, and there were no libssp-0.dll in RT folder, actually.

But this is still quite a mystery, because previous RT_dev_2313 (also extracted from downloaded zip package) runs perfectly, is stable, yet also does not contain libssp-0.dll.

I found that libssp-0.dll could be downloaded alone from internet, but even when I did so and saved it in RT folder it did not help - just an error were different - but RT still did not start.

I am not a programmer, but maybe something in automatic build system should be corrected?

Regards,

Aleks

Thank you for reporting, the issue is noted in our bug tracker https://github.com/Beep6581/RawTherapee/issues/5841

@AlLegro the problem should be fixed in the latest dev packages. Could you please check and confirm? See discussion here: https://github.com/Beep6581/RawTherapee/issues/5841

Hi,

Thank you very much. I can confirm that developer version 5.8-2364 works on my computer.

However, larger png and tif files seem to be invisible for this version of RT: for example I have 4 images in one folder, each approx. 360 Mpx (19600x18300 px, xcf, jpg, png and tif - all except jpg are 16 bits per color channel) and only jpg is recognized by RT. It is quite strange, because I worked with even larger images last year (my computer has 32 GB RAM coupled with Ryzen 1600). Xcf is “proprietary” GIMP format, so it is normal that RT does not display it in File Viewer tab (I hope it’s File Viewer in English - first tab from the top at the left border - just translated Polish name by myself) but only the jpg file miniature is visible there - there are no miniatures for png and tif. I can open all the pictures in GIMP.

Has something changed in RT in this area?

Regards,

Aleks