Import from NAS (with ubuntu)


(Mattia Minini) #1

I’ve tried to import from a folder on my NAS but it is impossible.
I’ve mounted the folder, but the darktables file browse don’t show “mounted” folders

I’ve tried the same process with GIMP and it shows the folders

Do you know if it is on roadmap, to fix this problem?

Thank you


#2

Hi @Mattia_Minini & welcome!

Hopefully you will find some clues here:
https://www.linuxquestions.org/questions/linux-hardware-18/how-to-permanently-map-network-folder-4175620783/

Have fun!
Claes in Lund, Sweden


(Mattia Minini) #3

@Claes thank you for your answer.
But I’ve mounted of the network folder correctly.
The problem seems to be related to the tool used by darktable to browse folders:
https://redmine.darktable.org/issues/10790
I’m reading this post but I don’t understand if it is fixed or not…

So I’m searching another linux user that has resolved this problem


(pphoto) #4

I had the same problem on Ubuntu 18.04 after installing Darktable from Ubuntu’s Software Center. I found the advice to reinstall it from another place (maybe a PPA), but I don’t remember which one that was.
After installing Darktable from another source it worked (same for OpenCL, btw).


(Mattia Minini) #5

Thank you, I will try to reinstall with this…
http://linuxg.net/how-to-install-darktable-2-4-4-on-ubuntu-18-04/


(Pascal Obry) #6

If you had 2.6 you can’t go back to 2.4.


(Mattia Minini) #7

@pphoto give me an hope. I need to find the correct ppa and reinstall it


(Mattia Minini) #8

I unistalled the version installed from “Ubuntu Software” and reinstalled it with http://ubuntuhandbook.org/index.php/2018/04/install-darktable-2-4-3-ubuntu-18-04/


(pphoto) #9

Can you now import from NAS?


(Mattia Minini) #10

@pphoto yes


#11

I can import from my LAN Synology NAS using NFS mounted connections. I have DT installed on two PCs running Linux Mint 18.3 MATE. NFS has to be installed on the PC, and the appropriate menu in the NAS filled in to use it there.

The version of DT I’m using is the latest “flatpak” version, 2.6.0, not available from the repository for Mint 18.3 or its underlying Ubuntu version.

I can list here the script I use for mounting and dismounting if anyone wants it.