Installation failed

tried to install today on latest debian 10
a menu item has beed added, but it does not work.

How did you install it? On which distro?

I just donwloaded and ran the installation script.

Installing applicationā€¦

Processing /tmp/tmpzbyoyxse/rapid-photo-downloader-0.9.26.tar.gz
Building wheels for collected packages: rapid-photo-downloader
Building wheel for rapid-photo-downloader ( started
Building wheel for rapid-photo-downloader ( finished with status ā€˜doneā€™
Created wheel for rapid-photo-downloader: filename=rapid_photo_downloader-0.9.26-py3-none-any.whl size=6449854 sha256=785efcd651dbd74424438351aaf9038dfbafd0fa6b2a9c1fa49bb49b2e2dfd7a
Stored in directory: /home/martin/.cache/pip/wheels/2b/ae/fc/8ee8795077d2ab563a67b228ec09b8b78ec2616a5ef1ebd5e4
Successfully built rapid-photo-downloader
Installing collected packages: rapid-photo-downloader
Successfully installed rapid-photo-downloader-0.9.26

it does not work after reboot

Detected Linux distribution Debian 10

Downloading (8.21 MB)
0% [##############################] 100% | ETA: 00:00:00
Total time elapsed: 00:00:02

Determining most appropriate PyQt5 packageā€¦
ā€¦will use PyQt5 packaged by Debian.

Querying package system to see if an older version of Rapid Photo Downloader is installed (this may take a while)ā€¦
Checking if previous version installed with pipā€¦
Found existing installation: rapid-photo-downloader 0.9.26
Uninstalling rapid-photo-downloader-0.9.26:
Successfully uninstalled rapid-photo-downloader-0.9.26

Installing application requirementsā€¦

Have you restarted or logged in/out?

yes reboot. please note that I am running XFCE as window manager

when I search for ā€œrapid-photo-downloaderā€, I do not find any filename that matches. Only the desktop.entry is added to the /home/martin/.local/share/applications/

I also did run a search in /usr no match anywhere.

I think the executable is not found not installed.

Can you find it on the terminal?

Did you run the installer as root? My bet is that it got installed in your home directory in a location not in your PATH.

Installation instructions have been followed: I ran the script on my personal account name. Not root. The .desktop shortcut has been created in my home account subdirectory.

find . -name rapid-photo-downloader -print
martin@debian:~$ echo $PATH

I added ~./.local/bin to PATH and it works now.
case closed.
Thank you

1 Like