Invisible Watermark Broken?

G’MIC for Gimp has a filter that appears to be broken. It is the Fourier Watermark (under “Frequencies”).
I tried uninstalling the current Gimp and G’MIC, and then reinstalling, but nothing changed. I just watermarked an image on 5/1/2022. but as of today, 5/4/2022 it has stopped working. Spent about 10 hours trying to figure this out, but am stuck. Tried on another computer, same result.

When you say “it’s broken”, what does it mean exactly ?
Have you an error message? Or the filter just returns without doing anything?

When viewed with the “Fourier Analysis” nothing shows up. I.E., it isn’t working. No error messages.

Works here, kubuntu 20.04 / gmic 3.1.0

Just fits into a one minute demo: although the gmic window strayed out of the capture area.

If you are using Windows, reinstalling Gimp / g’mic rarely works, All the settings are held in your Gimp and g’mic profiles in C:\Users"yourname"\AppData\Roaming which remains between installations.

Edit: Looks like it is a Windows issue. Just got round to trying in Win 10 (VM) / Gimp 2.10.30 / latest gmic 3.1.0 (zipped version).
…and the fourier watermark filter produces nothing.

Thanks for trying it in Windows.

Given it a deeper try in that Win10 (VM) and it does work when exporting to a png but not when exporting to a jpg.
You do need to open the file in Gimp, the gmic preview shows nothing and for ‘Lenna’ not so easy to see.

I’ll try it in Win 10 VM. Have to install it all first. I think JPG doesn’t work because compression can destroy the watermark–it is not a robust watermarking system. Oddly, I tried the “filter” on a Windows 7 install, and it is broken, too.

VM didn’t work for me, either. Used a fresh install of newest GIMP and G’MIC. By the way, VM and literal Windows are both Win10 Pro.