Latest Gimp AppImage and packaged Gmic do not play well together

Hello everyone. I am having an ongoing issue that has plagued me for quite a few editions of aferrero’s Gimp AppImage releases concerning GMIC working properly as it is packaged when downloading the “with plugins” edition of his AppImages.

Currently, I have d/l’ed version 2.10.25 of Gimp from here:

https://github.com/aferrero2707/gimp-appimage/releases/tag/continuous

and have the same results I have had for almost a year, it seems, now. The prepackaged GMIC built into the AppImage throws out preview errors on virtually every other filter choice when using GMIC.

Updating to the very latest GMIC seems to have no positive effect. Downloading the AppImages without plugins and then using the latest GMIC doesn’t display preview errors, but it crashes after each filter is applied.

I’ve worked with a wonderfully knowledgeable man named Rich2005 from Gimp-Forum.net. He has made it possible to d/l the latest AppImage and have a functional GMIC plugin by providing me with a modified, yet unfortunately outdated, GMIC plugin.

I used to be able to simply d/l the Gimp AppImage “with plugins” and GMIC would work great. Does anyone know what changed? Does anyone know of perhaps another place to get good, up to date AppImages that work properly without shortcuts/fixes, etc…

My OS is Linux Mint. Thanks.

Does anyone know of perhaps another place to get good, up to date AppImages that work properly without shortcuts/fixes, etc…

No other builds that I know of. A fix it has to be.
The aferrero’s appimage is a great build, very clever. The gimp_gmic_qt 2.9.2 July '20 is in gmic terms ancient, many changes in syntax since then. I think it comes from the older QT libraries used, gimp_gmic_qt needs compiling using compatible versions.

What does work: This in a kubuntu 20.04 / 2.10.25 appimage-with-plugins.

The ubuntu 2.8 plugin
https://gmic.eu/files/linux/gmic_2.9.7_gimp2.8_ubuntu18-04_bionic_amd64.zip Says Gimp 2.8 but works. This the latest-&-greatest filter.
https://i.imgur.com/n4UzZuz.jpg
or
I keep a version for 'buntu 18.04 users
https://www.gimp-forum.net/Thread-gmic-gimp-qt-and-Ubuntu-18-04
https://i.imgur.com/W5Xefi6.jpg

Either of those unzipped and in ~/.config/GIMP-AppImage/2.10/plug-ins/ will supercede the older plugin.

2 Likes

You come through again, Rich. It’s the latest release of GMIC, doesn’t crash, and doesn’t have never-ending preview errors either.

Your 2.92 version of GMIC worked right along but I kind of felt like things were passing me by. I should have just come back to Gimp-Forum and talked to you first but, I had never posted here and just found the site and wanted to sign up and get a post in.

Thanks a million, again.

I’m using the same AppImage as you and I went into some problem as well with G’MIC.
for the G’MIC version 2.9.7 and after reading some forum, usually for G’MIC Windows where they got a “similar” problem, I downloaded the G’MIC for GIMP for Ubuntu 20.04 (not the .deb package but the zip where you will find inside a file named gmic_gimp_qt)

I did delete (rename it first for testing) the one ( gmic_gimp_qt ) already in place in /usr/lib/gimp/2.0/plug-ins then put the new one instead and I also deleted (without replacing, just delete it/ or rename for testing) the old one ( gmic_gimp_qt ) in /usr/bin

and now everything is working properly

I also discovered that I have a bunch of gmic or gmic_qt and similar naming in those 2 directories, not sure if I can delete them, I remember that I deleted 2 of them on top of the ones above but don’t recall the exact naming, also I did lose all my faves, but at least it’s working fine :wink: