Lensfun lib error on startup.

I have installed ART from the Arch aur but am getting this error on startup:
ART: error while loading shared libraries: liblensfun.so.1: cannot open shared object file: No such file or directory

Looking in the /usr/lib folder I see the following files:

/usr/lib/liblensfun.so -> liblensfun.so.2
/usr/lib/liblensfun.so.2 -> liblensfun.so.0.3.95

Lensfun is installed and seems to work fine with Darktable.

I did try creating a new link to liblensfun.so.1 but this causes another error.

Can anyone help resolve this error?

Ping @guzzisti who is the arch packager iirc

Btw there is an issue with the latest version of glib2 in that causes art 1.8.3 to freeze sometimes, and this affects arch. I’m going to release 1.8.4 soon (hopefully later today) to fix this and a couple more glitches I found

1 Like

Thanks, I’ll send over a msg now.

This seems odd, i just rebuilt ART this morning on my machine and everything is fine.

Which package did you use? art-rawconverter-git or art-rawconverter? What distro do you use?
Are you sure you are starting the correct binary of ART?

Your lensfun libs look good to me, it’s exactly the same on my machine.

lrwxrwxrwx 1 root root     15 11. Nov 16:07 /usr/lib/liblensfun.so -> liblensfun.so.2*
-rwxr-xr-x 1 root root 339304 11. Nov 16:07 /usr/lib/liblensfun.so.0.3.95*
lrwxrwxrwx 1 root root     20 11. Nov 16:07 /usr/lib/liblensfun.so.2 -> liblensfun.so.0.3.95*

I had tried both packages.
I’ve just been checking for other versions and it seems there were other binaries in /usr/local/bin for ART and ART-cli dated Jan 24 2020, removing these and now it works fine with the correct versions in /usr/bin .

Thanks for the help.

1 Like